zfs-discuss@opensolaris.org
[Top] [All Lists]

[zfs-discuss] ZFS Volume Destroy Halts I/O

Subject: [zfs-discuss] ZFS Volume Destroy Halts I/O
From: Nick
Date: Mon, 15 Feb 2010 08:31:12 PST
I've seen threads like this around this ZFS forum, so forgive me if I'm 
covering old ground.  I currently have a ZFS configuration where I have 
individual drives presented to my Opensolaris machine and I'm using ZFS to do a 
RAIDZ-1 on the drives.  I have several filesystems and volumes on this storage 
pool.  When I do a "zfs destroy" on a volume (and possibly a filesystem, though 
I haven't tried that, yet), I run into two issues.  The first is that the 
destroy command takes several hours to complete - for example, destroying a 10 
GB volume on Friday took 5 hours.  The second is that, while this command is 
running, all I/O on the storage pool appears to be halted, or at least paused.  
There are a few symptoms of this...first, NFS clients accessing volumes on this 
server just hang and do not respond to commands.  Some clients hang 
indefinitely while others time out and mark the volume as stale.  On iSCSI 
clients, the clients most often time out and disconnect from the iSCSI vol
 ume - which is bad for my clients that are booting over those iSCSI volumes.

I'm using the latest Opensolaris dev build (132) and I have my storage pools 
and volumes upgraded to the latest available versions.  I am using 
deduplication on my ZFS volumes, set at the highest volume level, so I'm not 
sure if this has an impact.  Can anyone provide any hints as to whether this is 
a bug or expected behavior, what's causing it, and how I can solve or work 
around it?

Thanks,
Nick
-- 
This message posted from opensolaris.org
_______________________________________________
zfs-discuss mailing list
zfs-discuss@xxxxxxxxxxxxxxx
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

<Prev in Thread] Current Thread [Next in Thread>