zfs-discuss@opensolaris.org
[Top] [All Lists]

Re: [zfs-discuss] 2008.11 rc2 weird zpool import behaviour

Subject: Re: [zfs-discuss] 2008.11 rc2 weird zpool import behaviour
From: petede
Date: Thu, 27 Nov 2008 22:44:32 +0000
Udo Grabowski wrote:
> Tried setting the mountpoint explicitly already, gives exactly the same 
> behaviour.  There wasn't a directory of the same name (tried with /a existing 
> and /a not existing before the import/mountpoint setting), and zpool status
> and zfs list show exactly what is expected. But only the mountpoints under /a
> and a few of the subdirectories there appear, not a single file. zpool status 
> before the
> import was empty, so no duplicate rpool. Tried setting mountpoint to legacy
> and mounted by hand somewhere, exactly the same strange appearance.
> We've root on zfs over a year now with SXDE 01/08 (fiddled at lot with zfs to 
> get it 
> running before it was officially possible), and never have seen such a 
> behaviour.

That is odd - I just went through it here on a virtualbox system:

o boot from the iso image
o fire up an terminal window and did the following:
        zpool import -f rpool
o cd /rpool and this only shows two directories for boot and etc        
o zfs set mountpoint=/foo rpool/ROOT/opensolaris
o zfs mount rpool/ROOT/opensolaris
o ls /foo and all the pieces are there

Is this what you are doing ? Note /foo did not exist.

ta
pete
_______________________________________________
zfs-discuss mailing list
zfs-discuss@xxxxxxxxxxxxxxx
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

<Prev in Thread] Current Thread [Next in Thread>