zfs-discuss@opensolaris.org
[Top] [All Lists]

Re: [zfs-discuss] Is there _any_ suitable motherboard?

Subject: Re: [zfs-discuss] Is there _any_ suitable motherboard?
From: Nathan Kroenert
Date: Mon, 27 Aug 2007 10:12:19 +1000
For what it's worth, I bought a Gigabyte GA-M57SLI-S4 a couple of months 
ago and it rocks on a reasonably current Nevada.

Certainly not the cheapest or most expensive, but I felt a good choice 
for multiple PCI-E slots and a couple of PCI slots.

http://www.gigabyte.com.tw/Products/Motherboard/Products_Spec.aspx?ClassValue=Motherboard&ProductID=2287&ProductName=GA-M57SLI-S4

Everything on it worked a treat for me, and paired with an Nvidia 
7900GS, has handled pretty much whatever I have thrown at it, including 
Second Life on Solaris. :)

On Nevada (at the time I build it, it was NV_65), everything just worked 
straight out of the box. Gig Ethernet, IDE ports, SATA ports (in 
compatability mode), USB, 1394, audio, dual core stuff, the lot.

SATA ports work fine and dandy (up to about 70MB/S per port on the outer 
edge of the disk using Seagate 320GB 16MB cache 7200RPM disks) using the 
IDE emulation. I'm waiting for the build of nevada that provides the 
Nvidia MCP55 SATA controller support for native SATA stuff. Not long 
now... ZFS seems to be able to write down the channel's at about 
80MB/s... (At least on a brand spanking new Zpool. Seems closer to 
60MB/s now...)

Once the Nvidia SATA stuff goes back, you'll have 6 ports of NVidia SATA 
goodness straight off the board. (and even now, you have 6 ports of 
reasonable speedyness in good old ATA mode.)

 From what I can tell, the Nvidia SATA devices hang straight off the 
PCI-E bus, so you might even be able to get 'em all running flat out. 
(Though, I'm basing this on the output of the prtconf, I could be 
completely wrong.) See bottom of post for the prtconf -D output.

I'm also running it as a Solaris Xen Dom0 with other OS/s lurking on top 
of that, so the HVM support also works great.

I have just submitted this board to the HCL for SXDE, and if I get a 
chance, I'll pull the latest S10 and give that a whirl too.

Hope this helps. (and excuse the prtconf being from the Xen boot, rather 
than bare metal... got a bit of stuff happening on the box at the moment 
and did not feel like rebooting. ;)

/root # prtconf -D
System Configuration:  Sun Microsystems  i86pc
Memory size: 3895 Megabytes
System Peripherals (Software Nodes):

i86xpv (driver name: rootnex)
     scsi_vhci, instance #0 (driver name: scsi_vhci)
     isa, instance #0 (driver name: isa)
         fdc, instance #0 (driver name: fdc)
             fd, instance #0 (driver name: fd)
         asy, instance #0 (driver name: asy)
         lp, instance #0 (driver name: ecpp)
         i8042, instance #0 (driver name: i8042)
             keyboard, instance #0 (driver name: kb8042)
         motherboard
     xpvd, instance #0 (driver name: xpvd)
         xencons, instance #0 (driver name: xencons)
         xenbus, instance #0 (driver name: xenbus)
         domcaps, instance #0 (driver name: domcaps)
         balloon, instance #0 (driver name: balloon)
         evtchn, instance #0 (driver name: evtchn)
         privcmd, instance #0 (driver name: privcmd)
     pci, instance #0 (driver name: npe)
         pci1458,5001
         pci1458,c11
         pci1458,c11
         pci1458,c11
         pci1458,5004, instance #0 (driver name: ohci)
             mouse, instance #1 (driver name: hid)
         pci1458,5004, instance #0 (driver name: ehci)
         pci-ide, instance #0 (driver name: pci-ide)
             ide, instance #0 (driver name: ata)
                 sd, instance #1 (driver name: sd)
                 sd, instance #0 (driver name: sd)
             ide (driver name: ata)
         pci-ide, instance #1 (driver name: pci-ide)
             ide, instance #2 (driver name: ata)
                 cmdk, instance #0 (driver name: cmdk)
             ide, instance #3 (driver name: ata)
                 cmdk, instance #1 (driver name: cmdk)
         pci-ide, instance #2 (driver name: pci-ide)
             ide (driver name: ata)
             ide (driver name: ata)
         pci-ide, instance #3 (driver name: pci-ide)
             ide (driver name: ata)
             ide (driver name: ata)
         pci10de,370, instance #0 (driver name: pci_pci)
             pci8086,1e, instance #0 (driver name: e1000g)
             pci1458,1000, instance #0 (driver name: hci1394)
         pci1458,a002, instance #0 (driver name: audiohd)
         pci1458,e000, instance #0 (driver name: nge)
         pci10de,377, instance #0 (driver name: pcie_pci)
             display, instance #0 (driver name: nvidia)
         pci1022,1100 (driver name: mc-amd)
         pci1022,1101 (driver name: mc-amd)
         pci1022,1102 (driver name: mc-amd)
         pci1022,1103, instance #0 (driver name: amd64_gart)
     iscsi, instance #0 (driver name: iscsi)
     pseudo, instance #0 (driver name: pseudo)
     options, instance #0 (driver name: options)
     agpgart, instance #0 (driver name: agpgart)
     xsvc, instance #0 (driver name: xsvc)
     used-resources
     cpus
         cpu, instance #0
         cpu, instance #1


Nathan.

Ben Middleton wrote:
> I've just purchased an Asus P5K WS, which seems to work OK. I had to download 
> the Marvell Yukon ethernet driver - but it's all working fine. It's also got 
> a PCI-X slot - so I have one of those Super Micro 8 port SATA cards - 
> providing a total of 16 SATA ports across the system. Other specs are one of 
> those Intel E6750 1333MHz FSB CPUs and 2Gb of matched memory.
> 
> Ben.
>  
>  
> This message posted from opensolaris.org
> _______________________________________________
> zfs-discuss mailing list
> zfs-discuss@xxxxxxxxxxxxxxx
> http://mail.opensolaris.org/mailman/listinfo/zfs-discuss
_______________________________________________
zfs-discuss mailing list
zfs-discuss@xxxxxxxxxxxxxxx
http://mail.opensolaris.org/mailman/listinfo/zfs-discuss

<Prev in Thread] Current Thread [Next in Thread>