xboard-devel@gnu.org
[Top] [All Lists]

Re: [XBoard-devel] 4.4.0 issues

Subject: Re: [XBoard-devel] 4.4.0 issues
From: Eric Mullins
Date: Sat, 19 Sep 2009 12:01:45 -0600
h.g. muller wrote:

Other input here would be helpful, probably. Occasionally, I want to mute for other reasons. Like if I get a phone call while I'm involved in a game. In that case, I generally want to silence everything associated with the chess program. So I guess my choice would be an option to mute all sounds.

Would it be an idea to automatically mute all sounds when XBoard is iconified?

Probably not. I don't usually iconify when I need to mute it. Sometimes I need to mute when involved in a game. In that case, I most definitely can't iconify!

2: If I make the move before the opponent, then after he moves, nothing happens and I have to make it again. No, I don't get the premove highlights.

In testing this to check on question 2, it appears to be working now (with highlights). I didn't change anything that I know of. So forget it for now and if I see it again, I'll bring it up again with more information.
1: Both winboard and xboard.

Other people have complained about premove too, but if there is a bug it has proven very illusive. For me and Arun it aways seems to work. I did find a bug in WinBoard, (introduced by myself when I fixed the promotion popup, because I did not properly understand the premove logic at that time), which I fixed before the 4.4.0 release. I never touched this part of the code for XBoard; it still suffers from the promotion popup appearing on moves that are illegal no matter what you promote to.

One thing is sure, though: if you don't see premove highlights, no premove has been entered. In this case it would be interesting to know if the entering process went astray when entering the from square or the to square. Normal behavior is that when clicking the from square it gets a normal highlight, which then turns to the premove highlight color when you click the to square. Of course you can also drag and drop a piece; in that case the premove highlights should appear on both from and to square after you drop the piece. (It would also be relevant to know if any trouble
you experience would occur on drag-drop or click-click moves.)


I've seen it a couple more times since then. But I don't have any additional information about why it's happening, so I haven't mentioned it. I never click twice-- I always drag to make the move.



<Prev in Thread] Current Thread [Next in Thread>