ubuntu-users@lists.ubuntu.com
[Top] [All Lists]

Re: update-alternatives --config java

Subject: Re: update-alternatives --config java
From: Karl Auer
Date: Mon, 27 Aug 2007 13:10:40 +1000
On Mon, 2007-08-27 at 03:29 +0100, Wulfy wrote:
> update-java-alternatives...  :@)

Thank you! Missed that badly.

But: I have GCJ, Sun/Blackdown 1.4.2-02, Sun 1.6 and Sun 1.6 installed.
I am still using 1.4 for production work. The --list option does not
show 1.4, even though I did install it from the Ubuntu repositories:

kauer@karl:~$ sudo update-java-alternatives --list
java-1.5.0-sun 53 /usr/lib/jvm/java-1.5.0-sun
java-6-sun 63 /usr/lib/jvm/java-6-sun
java-gcj 1041 /usr/lib/jvm/java-gcj

Why is this? It seems to mean that if I ever move away from 1.4, I will
have no (easy) way back...

The Ubuntu versions are pretty old too. I am starting to feel that the
Ubuntu way, at least for real Java development, is not good enough, and
that I will have to de-install all these Ubuntu packages and install the
Sun stuff myself the hard way...

Regards, K.

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Karl Auer (kauer@xxxxxxxxxxxxxx)                   +61-2-64957160 (h)
http://www.biplane.com.au/~kauer/                  +61-428-957160 (mob)


-- 
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

<Prev in Thread] Current Thread [Next in Thread>