[email protected]
[Top] [All Lists]

[Samba] Samba 3.0 build with ADS support on Solaris 9

Subject: [Samba] Samba 3.0 build with ADS support on Solaris 9
From: "Jagga Soorma"
Date: Wed, 7 Jun 2006 10:59:46 -0700
Hey Guys,

I have trying to build Samba 3.0 with ADS support on Solaris 9.  This is how
I am trying to configure samba:

./configure     --prefix=/usr/local/samba \
               --with-ldap \
               --enable-static \
               --with-ads \
               --with-krb5 \
               --with-libiconv \

I have set the LD_LIBRARY_PATH:
export LD_LIBRARY_PATH="/opt/sfw/lib:/usr/local/lib:/usr/lib"

ls /opt/sfw/lib
liblber.a             liblber.so.2          libldap.la
libldap_r.so          libldap.so
liblber.la            liblber.so.2.0.122    libldap_r.a
libldap_r.so.2        libldap.so.2
liblber.so            libldap.a             libldap_r.la
libldap_r.so.2.0.122  libldap.so.2.0.122

The error I am receiving when I run the configure is:

checking for lber.h... yes
checking for ber_scanf in -llber... no
checking for ldap_init in -lldap... no
checking for ldap_set_rebind_proc... no
checking whether ldap_set_rebind_proc takes 3 arguments... 3
configure: error: libldap is needed for LDAP support

Any ideas what I am missing?  Libldap seems to be there so how come
configure is not seeing it?

Any suggestions or comments would be grately appreciated.

To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

<Prev in Thread] Current Thread [Next in Thread>