samba@lists.samba.org
[Top] [All Lists]

Re: [Samba] "NT_STATUS_LOGON_FAILURE"

Subject: Re: [Samba] "NT_STATUS_LOGON_FAILURE"
From: Donald Musser
Date: Fri, 16 Dec 2005 15:54:02 -0500
Yeah, the smbclient -L localhost -U% command works fine and returns data as
I'd expect. I've also found that I cannot modify passwords for my defined
usernames. Here's what I get when I try.

[root@localhost samba]#smbpasswd -a username
New SMB password:
Re-type new SMB password:
Unable to open/create TBD passwd
pdb_getsampwnam: Unable to open TDB password (/etc/samba/passdw.tbd)!
TDBSAM version too old (0), trying to convert it.
TDBSAM converted successfully.
tdb_update_sam: Failing to store a SAM_ACCOUNT for [mmusser] without a
primary group RID
Failed to add entry for user username.
Failed to modify password entry for user username

I get this error with and without the  -a argument. Any ideas?

Also, I'm not using any logon scripts. Are they necessary? I was under the
impression they were only needed if you wanted to auto-mount drives on login
and things like that.

-Myles



On 12/16/05, Michael Barnes <mbarnes@xxxxxxxx> wrote:
>
> I got that error when trying to login or access the Samba server from a
> client who was not allowed in the [IPC$] section.
>
>
> [IPC$]
>     path = /tmp
>     hosts allow = 10.143.0.0/16, 127.0.0.1, 10.159.0.0/16, 10.150.0.0/16
>     hosts deny = 0.0.0.0/0
>
> Be sure you are in this section to have permission to access the server.
>
> Of course, there are other reasons to get that message, but this is the
> one that pertained to me.  At least it is someplace to look.
>
>
> Also, try 'smbclient -L <servernetbiosname> -U%'.
> If that works and 'smbclient -L <servernetbiosname> -U <username>' does
> not, then it may be a user vs. share issue.
>
>
> Michael
>
>
> Donald Musser told me on 12/16/2005 13:39:
> > Hi everyone,
> >
> > I'm using the online HOWTO manual in the "Quick Start" reference to try
> and
> > get a basic domain controller going. So I set up smb.conf, and testparm
> > checked out okay, I've started nmbd and smbd, but when I try to to run
> >
> > [root@localhost samba]#smbclient -L <username> -U<username>%<password>
> > session setup failed: NT_STATUS_LOGON_FAILURE <-- I get this error
> >
> > Any ideas about what's causing this? I can post any relevant info as
> needed..
> >
> > -Myles
>
--
To unsubscribe from this list go to the following URL and read the
instructions:  https://lists.samba.org/mailman/listinfo/samba

<Prev in Thread] Current Thread [Next in Thread>