[email protected]
[Top] [All Lists]

3.0.20 compile failure

Subject: 3.0.20 compile failure
From: Randy McMurchy
Date: Sat, 10 Sep 2005 20:12:32 -0500
Hi all,

Sorry if this is the wrong list. I mailed a similar message to the
general Samba list and received no replies. Here's the link:


More details follow:

I'm using GCC-4.0.1 to compile. You can see the machine details in
the sig of the posting at the link above. Here's the configure
command I used that triggers the failure in make:

./configure --prefix=/usr \
            --sysconfdir=/etc \
            --localstatedir=/var \
            --with-piddir=/var/run \
            --with-fhs \
            --with-smbmount \
            --with-pam \
            --with-smbwrapper \
            --with-pam_smbpass \
            --with-python=python \

I've pinned the problem to a commit to the source/include/includes.h
file. Here's the specific commit that gives me problems:


I can't remember exactly what the error message was I received
when I compiled it initially, and I've since commented out the
offending area and built the package fine. If anyone is interested
I can reproduce the error and post it.

Let me know if I can provide any additional information.


rmlscsi: [GNU ld version 20041220] [gcc (GCC) 3.4.3]
[GNU C Library stable release version 2.3.4] [Linux 2.6.10 i686]
20:03:01 up 161 days, 19:36, 3 users, load average: 0.38, 0.41, 0.22

<Prev in Thread] Current Thread [Next in Thread>