redhat-install-list@redhat.com
[Top] [All Lists]

Re: Linux Error :113 No route to host

Subject: Re: Linux Error :113 No route to host
From: Chris Hewitt
Date: Thu, 30 Jun 2005 19:27:10 +0100
PS Bottom posting is preferred here (put your comments at the end). I'll
reorder this.
> 
On Thu, 2005-06-30 at 11:05, drumil narayan wrote:
> --- Chris Hewitt <rhil@xxxxxxxxxxxxxxxxxxxxx> wrote:
> 
> > On Wed, 2005-06-29 at 14:14, drumil narayan wrote:
> > > Hello,
> > > 
> > > I installed oracle 10.1.0.2 on RHEL 4.0
> > successfully.
> > > It was working fine.
> > > 
> > > Suddenly, it had started giving following error,
> > > while trying to connect oracle database from any
> > > windows client or on server it self..
> > > 
> > > TNS-12560:TNS: protocol Adapter Error
> > > TNS - 00530 : Protocol Adapter Error
> > > Linux error :113 : No route to host
> > > 
> > > any clues will be appreciated..Drumil
> > 
> > Drumil,
> > 
> > It looks like your networking has changed. Picking
> > the Oracle host from
> > your tnsnames.ora file that you are trying to get
> > to, can you ping it?
> > If so, can you tnsping it?
> > 
> > Either the networking on your computer has changed
> > or something between
> > you and the host you are trying to get to. Is the
> > host up and running,
> > is there a firewall change?
> > 
> > It sounds like it will be one of these.
> > 
> > Regards
> > 
> > Chris
> > 
> Hi Chris,
> 
> its pinging to and from othere clients.
> its tnspinging on server correctly.
> its not tnspinging from clients. 
> On server am able to database with and without connect
> string.
> 
> what could be the problem..thanx in advance..Drumil

I need to get this clear. The computer with RHEL on is the database
server? On the server, you can connect to the database (e.g. using
sqlplus) giving it the tnsnames.ora entry (not just the default blank
entry)?

>From other (client) computers you can ping the server, and tnsping the
server? Is this tnsping using the server hostname or an entry in
tnsnames.ora?

If you can successfully tnsping from a client using a tnsnames.ora entry
then you should be able to connect to the database.

The no route to host error I think can only be one of the things I said.
It does seem like something in your networking has changed, these things
do not happen by themselves. What can you think of that has changed?

Regards

Chris


_______________________________________________
Redhat-install-list mailing list
Redhat-install-list@xxxxxxxxxx
https://www.redhat.com/mailman/listinfo/redhat-install-list
To Unsubscribe Go To ABOVE URL or send a message to:
redhat-install-list-request@xxxxxxxxxx
Subject: unsubscribe

<Prev in Thread] Current Thread [Next in Thread>