rdiff-backup-users@nongnu.org
[Top] [All Lists]

Re: [rdiff-backup-users] rdiff backup doing is doing a full restore ever

Subject: Re: [rdiff-backup-users] rdiff backup doing is doing a full restore every time
From: Davy Durham
Date: Thu, 18 Aug 2005 15:39:10 -0500
Sorry.. my bad.. dumb user error.. turns out my restore script was using a backup tree from an older version of rdiff-backup

So it's working great!

-- Davy

Davy Durham wrote:

Question..

I'm using rdiff-backup 1.0.0 (no patches)
The backups were ONLY created with 1.0.0

For machines A, B and C,
   - I've done a backup from A to B
   - then I'm doing a restore from B to C

The first restore from B to C is transfering every file from A's backup to the system, C (I think every file.. looks like it at least) Then when it's done if I immediately do the same restore it copies everything again.. as if it's not seeing that all the files are then same as on the destination.
Running on B, the restore command line looks like:

rdiff-backup -v5 --print-statistics --exclude-device-files --exclude-filelist ../../bin/exclude.lst --exclude-globbing-filelist ../../bin/exclude.additionally_when_restoring.lst --restore-as-of 0D --force . root@C::/

Is --force the problem? I thought that makes it delete on the destination what didn't exist on the source which is how I want it to behave.

Any ideas?

Please Help,
  Davy




_______________________________________________
rdiff-backup-users mailing list at rdiff-backup-users@xxxxxxxxxx
http://lists.nongnu.org/mailman/listinfo/rdiff-backup-users
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki




_______________________________________________
rdiff-backup-users mailing list at rdiff-backup-users@xxxxxxxxxx
http://lists.nongnu.org/mailman/listinfo/rdiff-backup-users
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

<Prev in Thread] Current Thread [Next in Thread>