qt4-preview-feedback@trolltech.com
[Top] [All Lists]

Re: 4.4-rc1: Compile error in phonon:

Subject: Re: 4.4-rc1: Compile error in phonon:
From: Thiago Macieira
Date: Fri, 4 Apr 2008 19:37:48 +0200
On Friday 04 April 2008 09:21:30 Marc Mutz wrote:
> On Thursday April 3 2008 21:26, Thiago Macieira wrote:
> > On Thursday 03 April 2008 21:16:09 Jeff Tranter wrote:
> > > I see the same error on Debian Etch. I was able to build previous betas
> > > and the snapshots that I tried.
> > >
> > > I couldn't find a pbutils.h in any of the Debian gstreamer packages.
> >
> > Present in gstreamer 0.10.12 and later, according to the CVS tag on their
> > repository, which was released about one year ago.
> >
> > The configure script isn't checking for the minimum required version.
> > We'll probably have to change that.
>
> Well, Etch isn't that old yet. I suggest you reduce the minimum required
> version, or add a copy to 3rdparty/

We've changed Qt today to not use directly those symbols. They will be 
resolved at runtime, if the libgstpbutils-10.so.0 library is available.

If you want to test the change, it'll be in tonight's Qt 4.4.1 snapshots.

-- 
Thiago José Macieira - thiago.macieira AT trolltech.com
Trolltech ASA - Sandakerveien 116, NO-0402 Oslo, Norway
<Prev in Thread] Current Thread [Next in Thread>