qt-interest@trolltech.com
[Top] [All Lists]

Re: [Qt-interest] QMenu requires mouse movement...

Subject: Re: [Qt-interest] QMenu requires mouse movement...
From: Eric Clark
Date: Fri, 11 Jun 2010 13:51:22 +0000

> -----Original Message-----
> From: Frederic Tingaud [mailto:tingaud@xxxxxxxxxx]
> Sent: Friday, June 11, 2010 3:36 AM
> To: Eric Clark
> Cc: qt-interest@xxxxxxxxxxxxx
> Subject: Re: [Qt-interest] QMenu requires mouse movement...
> 
> Eric Clark a écrit :
> > Hello Everyone!
> >
> > Prior to the release of 4.6.2, I had a long discussion on this forum
> with many different people about a bug that we were seeing when
> hovering over an action that displays a menu. Basically, the menu
> should appear instantly when you hover over its associated action, and
> in most cases it does. But, when there is a QGLWidget in the main
> window, and you go to hover over the action, the menu appears
> translucent until you make a slight mouse movement. In my particular
> application, we have the ability to turn off the rendering on our
> QGLWidget, and when the rendering is turned off, the menu response to
> hover works just fine without the need for any extra mouse movement.
> >
> > After discussing this issue when the guys at trolltech and viewing
> the bug logs, we saw that it looked as though there was a bug fix for
> this issue to be released in Qt 4.6.2. However, after upgrading to
> 4.6.2, we still have the problem. Can anyone help me with this issue,
> Nokia/Trolltech guys? Does anyone know why the bug fix did not get in
> the 4.6.2 release and whether or not it is scheduled to be fixed
> anytime soon? Thank you in advance.
> >
> > Eric
> >
> >
> > ---------------------------------------------------------------------
> ---
> >
> > _______________________________________________
> > Qt-interest mailing list
> > Qt-interest@xxxxxxxxxxxxx
> > http://lists.trolltech.com/mailman/listinfo/qt-interest
> >
> Hi,
> 
> Did you check Qt 4.6.3 ? We had an issue that looked really like yours,
> where we needed to have a user event like a mouseMoveEvent or a
> KeyPressEvent to unfreeze our application and it was resolved by
> switching to 4.6.3.

I have not upgraded to 4.6.3 yet. I guess I will wait and see if it is fixed in 
that release before I post again. Hopefully, it will be fixed. Thank You!

> 
> --
> -----------------------------------------------------------------------
> --------
> Frederic TINGAUD
> -----------------------------------------------------------------------
> --------


_______________________________________________
Qt-interest mailing list
Qt-interest@xxxxxxxxxxxxx
http://lists.trolltech.com/mailman/listinfo/qt-interest

<Prev in Thread] Current Thread [Next in Thread>