On Thu, Sep 24, 2009 at 08:29:56PM +0200, Markus Armbruster wrote:
> "Michael S. Tsirkin" <mst@xxxxxxxxxx> writes:
> > On Tue, Sep 22, 2009 at 11:29:20AM +0200, Gerd Hoffmann wrote:
> >> @@ -890,15 +890,12 @@ PCIDevice *pci_find_device(int bus_num, int slot,
> >> int function)
> >> return bus->devices[PCI_DEVFN(slot, function)];
> >> }
> >> -PCIBus *pci_bridge_init(PCIBus *bus, int devfn, uint16_t vid, uint16_t
> >> did,
> >> - pci_map_irq_fn map_irq, const char *name)
> >> +static int pci_bridge_initfn(PCIDevice *dev)
> > pci_bridge_dev_init a better name?
> There's precedence for _initfn, _init1, and _init. I wish we'd pick one
> convention and stick to it.
The problem here is that we now have *both* pci_bridge_init and