[email protected]
[Top] [All Lists]

Re: [Qemu-devel] Boot Failure (CDROM boot failure code : 0004)

Subject: Re: [Qemu-devel] Boot Failure CDROM boot failure code : 0004
From: Laurent Vivier
Date: Mon, 16 Jun 2008 14:36:43 +0200
Hi,

could you burn a CD with your .iso and try to boot a real PC ?

Regards,
Laurent

Le lundi 16 juin 2008 Ã 15:08 +0300, Volkan YAZICI a Ãcrit :
> Hi,
> 
> I'm trying to install Windows Server 2003 Standard (x86-64) on a
> machine which has AMD Turion 64 X2 processor. I compiled and installed
> the qemu from source tarball using below commands:
> 
>   root:~# su - windows
>   windows:~$ mkdir qemu; cd qemu
>   windows:~/qemu$ wget http://bellard.org/qemu/qemu-0.9.1.tar.gz
>   windows:~/qemu$ tar -zxf qemu-0.9.1.tar.gz; cd qemu-0.9.1
>   windows:~/qemu/qemu-0.9.1$ ./configure --prefix=/home/windows/qemu
>   windows:~/qemu/qemu-0.9.1$ make && make install
> 
> And then I create the appropriate disk images.
> 
>   windows:~$ dd of=/home/windows/disk-raw-20g.img \
>   > bs=1024 seek=$[1024 * 1024 * 20] count=0
>   windows:~$ qemu/bin/qemu-img create -f qcow disk-qcow-20g.img 20G
>   windows:~$ qemu/bin/qemu-img create -f qcow2 disk-qcow2-20g.img 20G
> 
> When I try to boot Windows Server ISO image
> 
>   root:~# /home/windows/qemu/bin/qemu -boot d \
>   > -cdrom /home/windows/windows-server-2003-standard-x86-64-sp2.iso \
>   > -hda /home/windows/disk-qcow-20g.img \
>   > -localtime -m 512 -L /home/windows/qemu/share/qemu
> 
> qemu complains that
> 
>   QEMU BIOS - build: 02/08/07
>   $Revision: 1.174 $ $Date: 2006/10/17 16:48:05 $
>   Options: apmbios pcibios eltorito rombios32
> 
>   ata0 master: QEMU HARDDISK ATA-7 Hard-Disk (20480 MBytes)
>   ata1 master: QEMU CD-ROM ATAPI-4 Cd-Rom/Dvd-Rom
> 
>   CDROM boot failure code : 0004
>   Boot from Cd-Rom failed
>   FATAL: Could not read the boot disk
> 
> I also tried below combinations:
> 
>   1. -cdrom /dev/scd0
>   2. -hda /home/windows/disk-qcow2-20g.img
>   3. -hda /home/windows/disk-raw-20g.img
> 
> Besides qemu documentation, I read hundreds of blog posts, mailing list
> threads, forum junks about this problem, but nothing useful. I'll be
> really really appreciated if anybody can help me to solve the problem.
> 
> 
> Regards.
> 
> P.S. Sorry for bugging developers' mailing list, but forum
>      (http://qemu-forum.ipi.fi) subscription didn't work.     
> 
> 
> 
-- 
------------- [email protected] ---------------
"The best way to predict the future is to invent it."
- Alan Kay



<Prev in Thread] Current Thread [Next in Thread>