perl.beginners
[Top] [All Lists]

Installing perl-5.8.8

Subject: Installing perl-5.8.8
From: CyberDESI
Date: Thu, 27 Sep 2007 14:32:06 -0500
Newsgroups: perl.beginners
Hello,

If this is the wrong place to post please point out the correct list.

Here is the problem, I have RHEL AS 4 update 5 with perl v5.8.5. I would
like to install a newer version in /usr/local/perl5.8.8. I do the following:

sh Configure -de -Dprefix=/usr/local/perl5.8.8
make

[ I get the following errors]

`sh  cflags "optimize='-O2'" pp_pack.o`  pp_pack.c
          CCCMD =  cc -DPERL_CORE -c -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2  -Wall
`sh  cflags "optimize='-O2'" pp_sort.o`  pp_sort.c
          CCCMD =  cc -DPERL_CORE -c -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2  -Wall
rm -f libperl.a
/usr/bin/ar rcu libperl.a perl.o  gv.o toke.o perly.o op.o pad.o regcomp.o
dump.o util.o mg.o reentr.o hv.o av.o run.o pp_hot.o sv.o pp.o
scope.opp_ctl.o pp_sys.o
doop.o doio.o regexec.o utf8.o taint.o deb.o universal.o xsutils.o globals.o
perlio.o perlapi.o numeric.o locale.o pp_pack.o pp_sort.o
`sh  cflags "optimize='-O2'" opmini.o`  -DPERL_EXTERNAL_GLOB opmini.c
          CCCMD =  cc -DPERL_CORE -c -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2  -Wall
cc -L/usr/local/lib -o miniperl \
    miniperlmain.o opmini.o libperl.a -lnsl -ldl -lm -lcrypt -lutil -lc
./miniperl -w -Ilib -MExporter -e '<?>' || make minitest
Can't locate Exporter.pm in @INC (@INC contains: lib
/usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8
/usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux
/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .).
BEGIN failed--compilation aborted.
make[1]: Entering directory `/root/perl588/perl-5.8.8'
make[2]: Entering directory `/root/perl588/perl-5.8.8'
./miniperl -Ilib configpm --heavy=lib/Config_heavy.pl lib/Config.pm
Can't locate strict.pm in @INC (@INC contains: lib
/usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8
/usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux
/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at
configpm line 2.
BEGIN failed--compilation aborted at configpm line 2.
make[2]: *** [lib/Config.pod] Error 22
make[2]: Leaving directory `/root/perl588/perl-5.8.8'
make[1]: [minitest.prep] Error 2 (ignored)
 You may see some irrelevant test failures if you have been unable
to build lib/Config.pm, lib/lib.pm or the Unicode data files.

cd t && (rm -f perl; /bin/ln -s ../miniperl perl) \
        &&  ./perl TEST -minitest base/*.t comp/*.t cmd/*.t run/*.t io/*.t
op/*.t uni/*.t </dev/tty
Can't locate TestInit.pm in @INC (@INC contains:
/usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8
/usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux
/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at
TEST line 70.
BEGIN failed--compilation aborted at TEST line 70.
make[1]: [minitest] Error 22 (ignored)
make[1]: Leaving directory `/root/perl588/perl-5.8.8'
make: [extra.pods] Error 1 (ignored)
./miniperl -Ilib configpm --heavy=lib/Config_heavy.pl lib/Config.pm
Can't locate strict.pm in @INC (@INC contains: lib
/usr/local/lib/perl5/5.8.8/x86_64-linux /usr/local/lib/perl5/5.8.8
/usr/local/lib/perl5/site_perl/5.8.8/x86_64-linux
/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl .) at
configpm line 2.
BEGIN failed--compilation aborted at configpm line 2.
make: *** [lib/Config.pod] Error 22

Can someone point out what I am doing wrong? Thanks.

Mohsin
<Prev in Thread] Current Thread [Next in Thread>