opera.mac
[Top] [All Lists]

8.5.1 detecting wrong version of Java?

Subject: 8.5.1 detecting wrong version of Java?
From: David Westcott
Date: Thu, 15 Dec 2005 17:11:01 +0000
Newsgroups: opera.mac


I'm just testing some clever(?) KVM stuff that operates thru a Java applet
and have just spotted the following with Opera 8.51 on OSX 10.4.3 (and
previous versions it seems).

If you use the Sun Java Test page Opera 8.51 reports the JRE version as
"1.3.1_16" *BUT* in the OSX Terminal "java -version" reports the JRE as
"1.4.2_09-232"


The Sun Java test page is here:
<http://www.java.com/en/download/help/testvm.xml>


Why is Opera using an older version when other browsers including Safari
(v2.0.2) and Firefox (v1.5) recognise, report and use the later version -
1.4.2.


TIA

________________________________________________________________
David Westcott
Senior Team Leader - Workstations & Media Devices
Information Services, Cardiff University

[email protected]
________________________________________________________________


<Prev in Thread] Current Thread [Next in Thread>