netbsd-help@netbsd.org
[Top] [All Lists]

Re: audiorecord

Subject: Re: audiorecord
From: Volker Wolfram
Date: Sat, 23 Feb 2008 19:43:17 +0100 CET
Hi Leonardo,

your example dosen't work. I'm so sorry. Here are my output from the 
kernelmessage:

auacer0 at pci0 dev 4 function 0: Acer Labs M5455 Audio controller
auacer0: interrupting at irq 5
auacer0: ac97: Avance Logic ALC655 codec; no 3D stereo
auacer0: ac97: ext id 9c4<AC97_23,LDAC,SDAC,CDAC,SPDIF>
audio0 at auacer0: full duplex, independent

and here is the audioctl -a:

name=M5455 AC97
version=0x10
config=auacer0
encodings=slinear_le:16,slinear_be:16*,ulinear_le:16*,ulinear_be:16*,mulaw:8*,alaw:8*
properties=full_duplex,independent
full_duplex=0
fullduplex=0
blocksize=9600
hiwat=6
lowat=1
monitor_gain=0
mode=
play.rate=8000
play.channels=1
play.precision=8
play.encoding=mulaw
play.gain=207
play.balance=32
play.port=0x0
play.avail_ports=0x0
play.seek=0
play.samples=0
play.eof=0
play.pause=0
play.error=0
play.waiting=0
play.open=0
play.active=0
play.buffer_size=65536
record.rate=44100
record.channels=2
record.precision=16
record.encoding=slinear_le
record.gain=240
record.balance=32
record.port=0x1
record.avail_ports=0x7
record.seek=0
record.samples=0
record.eof=0
record.pause=0
record.error=0
record.waiting=0
record.open=0
record.active=0
record.buffer_size=65536
record.errors=0

and here are the settings of the mixer device:

outputs.master=207,207
outputs.master.mute=off
outputs.mono=255
outputs.mono.mute=on
outputs.mono.source=mixerout
outputs.surround=127,127
outputs.surround.mute=off
outputs.center=127
outputs.center.mute=off
outputs.lfe=127
outputs.lfe.mute=off
inputs.speaker=159
inputs.speaker.mute=off
inputs.phone=191
inputs.phone.mute=on
inputs.mic=191
inputs.mic.mute=off
inputs.mic.preamp=on
inputs.mic.source=mic0
inputs.line=191,191
inputs.line.mute=off
inputs.cd=191,191
inputs.cd.mute=off
inputs.video=255,255
inputs.video.mute=off
inputs.aux=191,191
inputs.aux.mute=off
inputs.dac=151,151
inputs.dac.mute=off
record.source=mic
record.volume=240,240
record.volume.mute=off
spdif.enable=off

Why does my recording fail?

Can anyone help me?

Volker

<Prev in Thread] Current Thread [Next in Thread>