netbsd-bugs@netbsd.org
[Top] [All Lists]

Re: lib/40346: libexpat should be in base.tgz

Subject: Re: lib/40346: libexpat should be in base.tgz
From: David Holland
Date: Sun, 25 Jan 2009 20:10:15 UTC
Newsgroups: fa.netbsd.bugs

The following reply was made to PR lib/40346; it has been noted by GNATS.

From: David Holland <dholland-bugs@xxxxxxxxxx>
To: gnats-bugs@xxxxxxxxxx
Cc: 
Subject: Re: lib/40346: libexpat should be in base.tgz
Date: Sun, 25 Jan 2009 20:08:58 +0000

 On Sun, Jan 25, 2009 at 10:40:04AM +0000, Alan Barrett wrote:
  >  Having now looked more carefully at the pkgsrc makefiles, I suspect that
  >  the problem was that the apache binary package was built on a system
  >  where IS_BUILTIN.expat was true, but was installed on a system without
  >  expat.  That won't work, and fixing it may require changes in the way
  >  binary packages deal with prerequisites that may or may not be "built
  >  in" to the host system.
 
 Right. Which seems like a good thing to handle properly.
 
  >  >  FWIW, I think if we're going to carry expat around anyway we may as
  >  >  well have it in base.
  >  
  >  I think that adding expat to base should have a beter reason than
  >  "there's something wrong in the way pkgsrc builds apache, and this is
  >  the quickest workaround we can think of".
 
 That's true, but there are a number of fairly good reasons. I suppose
 this part should be taken to tech-userlevel...
 
 -- 
 David A. Holland
 dholland@xxxxxxxxxx
 

<Prev in Thread] Current Thread [Next in Thread>