netbsd-bugs@netbsd.org
[Top] [All Lists]

xsrc/37266: xterm broken after updating to 4.0RC3, because links for lib

Subject: xsrc/37266: xterm broken after updating to 4.0RC3, because links for libXpm.so.4 are missing
From:
Date: Fri, 02 Nov 2007 16:30:33 UTC
Newsgroups: fa.netbsd.bugs

>Number:         37266
>Category:       xsrc
>Synopsis:       After updating NetBSD 1.6.1 to 4.0RC3 xterm won't start 
>because there were no softlinks to libXpm.so.4
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    xsrc-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 02 16:30:00 +0000 2007
>Originator:     Bernhard Moellemann
>Release:        NetBSD 4.0_RC3 from 24-10-2007
>Organization:
Home sweet Home
>Environment:
System: NetBSD daemonic 4.0_RC3 NetBSD 4.0_RC3 (GENERIC.NOACPI) #0: Wed Oct 24 
13:26:01 CEST 2007 
root@arcanic:/mnt/top/src/src-4.0/obj/sys/arch/i386/compile/GENERIC.NOACPI i386
/usr/X11/bin/xterm:
        -lX11.6 => /usr/X11R6/lib/libX11.so.6
        -lfreetype.9 => /usr/X11R6/lib/libfreetype.so.9
        -lexpat.4 => /usr/X11R6/lib/libexpat.so.4
        -lfontconfig.1 => /usr/X11R6/lib/libfontconfig.so.1
        -lXext.6 => /usr/X11R6/lib/libXext.so.6
        -lXrender.1 => /usr/X11R6/lib/libXrender.so.1
        -lXft.2 => /usr/X11R6/lib/libXft.so.2
        -lICE.6 => /usr/X11R6/lib/libICE.so.6
        -lSM.6 => /usr/X11R6/lib/libSM.so.6
        -lXt.6 => /usr/X11R6/lib/libXt.so.6
        -lXmu.6 => /usr/X11R6/lib/libXmu.so.6
        -lXpm.4 => /usr/X11R6/lib/libXpm.so.4
        -lXaw.7 => /usr/X11R6/lib/libXaw.so.7
        -ltermcap.0 => /usr/lib/libtermcap.so.0
        -lutil.7 => /usr/lib/libutil.so.7
        -lc.12 => /usr/lib/libc.so.12
Architecture: i386
Machine: i386

>Description:
xterm is linked against libXpm.4 but the update from 1.6.1 (and probably
the install or other updates) to 4.0RC3 does not create the links
libXpm.so -> libXpm.so.4.11 and libXpm.so.4 -> libXpm.so.4.11 so the
xterm failes with 'Shared object "libXpm.so.4" not found'

>How-To-Repeat:
Update from 1.6.1 to 4.0RC3, fire up the buildin XFree86 and start xterm. Watch 
it fail.

>Fix:
I did

# cd /usr/X11R6/lib
# ln -s libXpm.so.4.11 libXpm.so.4
# ln -s libXpm.so.4.11 libXpm.so

but I assume some mtree input files have to be extended

    Bernhard Möllemann  //
                      \X/


<Prev in Thread] Current Thread [Next in Thread>