netbsd-bugs@netbsd.org
[Top] [All Lists]

Re: kern/34935: if_re_pci.c needs updating

Subject: Re: kern/34935: if_re_pci.c needs updating
From: YAMAMOTO Takashi
Date: Mon, 30 Oct 2006 01:50:02 +0000 UTC
The following reply was made to PR kern/34935; it has been noted by GNATS.

From: yamt@xxxxxxxxxxxxxxxxx (YAMAMOTO Takashi)
To: perry@xxxxxxxxxxxx
Cc: tsutsui@xxxxxxxxxxxxxxx, gnats-bugs@xxxxxxxxxx,
        kern-bug-people@xxxxxxxxxx, gnats-admin@xxxxxxxxxx,
        netbsd-bugs@xxxxxxxxxx
Subject: Re: kern/34935: if_re_pci.c needs updating
Date: Mon, 30 Oct 2006 10:46:15 +0900 (JST)

 > > yamt said that hw ip4csum bug only happens with
 > > very small packet (less than ETHER_PAD_LEN) so FreeBSD's
 > > fix is not right.
 
 i'm not very sure about it.  it's merely my vague memory.
 if you can, please confirm.
 
 > > Furthermore, they choose to copy small packets
 > > to a new mbuf for padding, and several people object it.
 > 
 > When and if they find a better fix they can implement it.
 
 if it can't be done efficiently enough, there is no point to
 do the offloading at all.
 (it's the reason why it's currently disabled.
 ip header checksum offloading doesn't buy us much anyway,
 compared to, say, tcp checksum offloading.)
 
 YAMAMOTO Takashi
 

<Prev in Thread] Current Thread [Next in Thread>