microsoft.public.sqlserver.notificationsvcs
[Top] [All Lists]

Re: sample application in NS

Subject: Re: sample application in NS
From: Joe Webb
Date: Wed, 29 Jun 2005 05:42:44 -0500
Newsgroups: microsoft.public.sqlserver.notificationsvcs
Hi Yogesh - 

You're referencing the right dll for SQLNS 2005 in your project. But
that dll was developed for .NET Framework v2.0. 

VS.NET 2003 uses the v1.1 .NET Framework and cannot be used with
assemblies built with v2.0. 

As Shyam points out in another post, you have a couple of options:

1) Develop your Subscription Management App using VS.NET 2005.

2) Develop a web services wrapper around the SQLNS calls using VS.NET
2005 and call that from a VS.NET 2003 Subscription Management App. Not
a terribly convenient thing to do, but it should work.

HTH...

-- 
Joe Webb
SQL Server MVP


~~~
Get up to speed quickly with SQLNS
http://www.amazon.com/exec/obidos/tg/detail/-/0972688811 

I support PASS, the Professional Association for SQL Server.
(www.sqlpass.org)


On Wed, 29 Jun 2005 13:31:49 +0530, "Yogesh K."
<[email protected]> wrote:

>I am using SQL Server 2005 - Notification Services. 
>I am finding the problem as mentioned below while bulding a sample implemented 
>by me. 
>
>PLease let me know what has it got to do with and how can it be resloved. 
>
>Metadata file 'c:\Program Files\Microsoft SQL 
>Server\90\NotificationServices\9.0.242\bin\microsoft.sqlserver.notificationservices.dll'
> could not be opened -- 'Version 1.1 is not a compatible version.'
>
>I am implementing the sample using VS.NET 2003. 
>
>Yogesh Kadalgikar 


<Prev in Thread] Current Thread [Next in Thread>