microsoft.public.nl.office.excel
[Top] [All Lists]

ALS (EN) functie met meer dan 2 formule voorwaarden

Subject: ALS (EN) functie met meer dan 2 formule voorwaarden
From: "Dabu"
Date: Sat, 31 Jan 2009 16:29:22 +0100
Newsgroups: microsoft.public.nl.office.excel
Ik heb een vraagje om twee verschillende formules te laten werken in een cel 
of kollom in excel.

Even wat duidelijk maken wat de bedoeling is.
Het gaat over het berekenen van scores voor een bowling competitie
Bowling spelers krijgen een handicap.  Die handicap word berekend op het 
gemiddelde van hun gespeelde partijen. Nu is er ook een beperking op die 
handicap. Die beperking is dan ook verschillend voor de mannen als voor de 
vrouwen.
Die handicap mag voor de mannen niet hoger zijn dan 42.
Voor de vrouwen mag die niet hoger zijn dan 52.

In het excel document waar deze beperking word toegepast staan mannen en 
vrouwen door elkaar. Dit kan NIET veranderd worden.
In kollom H word de handicap beperking uitgevoerd, kollom V is waar de 
handicap word uitgerekend.  Nu moet ik alle 75 leden in die kollom van twee 
verschillende formules voorzien volgens man of vrouw.
Ik heb voor de mannen de volgende formule:  =ALS(V4>42;42;V4)
Ik heb voor de vrouwen de volgende formule: =ALS(V3>52;52;V3)

Ik heb ondertussen in kollom B een code ingevoerd die aanduid wie man of 
vrouw is. Ik heb dit gedaan door  de letter M voor de mannen in te brengen 
en V voor de vrouwen. Ik zou dit eventueel evengoed kunnen doen door 
bijvoorbeeld de mannen 1 te geven en de vrouwen 2, maar ik weet niet of dit 
een verschil zou geven.

Nu is mijn vraag of het mogelijk  is om dit twee formules te nestelen zodat 
ik niet iedere keer de verschillende formules voor de mannen en vrouwen moet 
ingeven.
Ik heb al eens geprobeerd maar geraak er niet uit, ze blijken niet te 
werken. De volgende kwam ik het dichtst bij maar werkte ook niet hij gaf mij 
wel de melding ONWAAR

=ALS(EN(B3="M";V3>42;42;V3);EN(B3="V";V3>52;52;V3))


Kan iemand mij helpen met wat ik fout doe of hoe ik zo iets moet oplossen.



Alvast bedankt!



<Prev in Thread] Current Thread [Next in Thread>