[email protected]
[Top] [All Lists]

Re: Colors on MC 4.7.0.1 are *really* a mess, seconded

Subject: Re: Colors on MC 4.7.0.1 are *really* a mess, seconded
From: Hugo Vanwoerkom
Date: Mon, 26 Apr 2010 09:04:29 -0700 PDT
--- On Sun, 4/18/10, Frank McCormick <[email protected]> wrote:

> From: Frank McCormick <[email protected]xxxxxxxx>
> Subject: Re: Colors on MC 4.7.0.1 are *really* a mess, seconded
> To: "Hugo Vanwoerkom" <[email protected]>
> Cc: [email protected]
> Date: Sunday, April 18, 2010, 2:29 PM
> On Sun, 18 Apr 2010 12:30:17 -0700
> (PDT)
> Hugo Vanwoerkom <[email protected]>
> wrote:
> 
> > Hi,
> > 
> > Mc user ever since the beginning. Running on Debian
> Sid.
> > Which upgraded mc to 4.7.0.1.
> > 
> > And the colors are a *mess* as I reported to Debian
> userlist:
> > http://lists.debian.org/debian-user/2010/04/msg00315.html
> > 
> > Nothing now works as before. As noted on this list:
> > http://mail.gnome.org/archives/mc/2010-March/msg00028.html
> > and a recent Debian bug:
> > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=567119
> > 
> > My color scheme was in the ini file:
> > 
> > [Colors]
> >
> base_color=executable=blue,white:viewunderline=yellow,black:normal=red,white:selected=lightgrey,lightgreen:marked=cyan,black:markselect=white,lightgreen:directory=black,white:link=red,white:device=lightgrey,black:special=cyan,black
> > 
> > That translates in 4.7.0.1 to something that gives an
> instantaneous splitting headache.
> > 
> 
> Â Try this skin Hugo.
> 
> Â put it in ~/.mc/skins
> 
> Â call mc with: mc --skin=special
> 
> Â I **think** it's what you want.
> 
> [skin]
> Â Â description=Dark Far skin
> 
> [Lines]
> Â Â lefttop=â
> Â Â righttop=â
> Â Â centertop=â
> Â Â centerbottom=â
> Â Â leftbottom=â
> Â Â rightbottom=â
> Â Â leftmiddle=â
> Â Â rightmiddle=â
> Â Â centermiddle=â
> Â Â horiz=â
> Â Â vert=â
> Â Â thinhoriz=â
> Â Â thinvert=â
> 
> [core]
> Â Â _default_=black;white
> Â Â selected=black;cyan
> Â Â marked=yellow;black
> Â Â markselect=yellow;cyan
> Â Â gauge=white;black
> Â Â input=black;cyan
> Â Â reverse=lightgray;black
> 
> [dialog]
> Â Â _default_=brightcyan;blue
> Â Â dfocus=blue;cyan
> Â Â dhotnormal=white;
> Â Â dhotfocus=white;cyan
> 
> [error]
> Â Â _default_=white;red
> Â Â errdhotnormal=yellow;red
> Â Â errdhotfocus=yellow;lightgray
> 
> [filehighlight]
> Â Â directory=gray;
> Â Â executable=brightmagenta;
> Â Â symlink=lightred;
> Â Â stalelink=brightred;
> Â Â device=brightmagenta;
> Â Â special=black;
> Â Â core=red;
> Â Â temp=gray;
> Â Â archive=brightgreen;
> Â Â doc=brown;
> Â Â source=cyan;
> Â Â media=green;
> Â Â graph=brightcyan;
> Â Â database=brightred;
> 
> [menu]
> Â Â _default_=lightgray;blue
> Â Â menuhot=white;blue
> Â Â menusel=black;cyan
> Â Â menuhotsel=white;cyan
> Â Â menuinactive=black;white
> 
> [help]
> Â Â _default_=black;lightgray
> Â Â helpitalic=red;lightgray
> Â Â helpbold=blue;lightgray
> Â Â helplink=black;cyan
> Â Â helpslink=yellow;blue
> 
> [editor]
> Â Â _default_=lightgray;black
> Â Â editbold=yellow;brightgreen
> Â Â editmarked=black;white
> Â Â editwhitespace=brightblue;black
> Â Â linestate=white;cyan
> Â Â bookmark=white;red
> Â Â bookmarkfound=black;green
> 
> [viewer]
> Â Â viewunderline=brightred;black
> 
> [buttonbar]
> Â Â hotkey=red;white
> Â Â button=black;white
> 
> [widget-common]
> Â Â sort-sign-up=â
> Â Â sort-sign-down=â
> 
> [widget-panel]
>   hiddenfiles-sign-show = â
>   hiddenfiles-sign-hide = â
> Â Â history-prev-item-sign = â
> Â Â history-next-item-sign = â
> Â Â history-show-list-sign = â
> 
> [widget-scollbar]
> Â Â first-vert-char=â
> Â Â last-vert-char=â
> Â Â first-horiz-char=Â
> Â Â last-horiz-char=Â
> Â Â current-char=â
> Â Â background-char=â
> 
> 
> 
> 
> 
> -- 
> Frank McCormick <[email protected]>
> 

Thanks Frank, sorry that it took a while to respond.
The reason that I made the original post is that when I use:

[Colors]
base_color=executable=blue,white:viewunderline=yellow,black:normal=red,white:selected=lightgrey,lightgreen:marked=cyan,black:markselect=white,lightgreen:directory=black,white:link=red,white:device=lightgrey,black:special=cyan,black
linux=
color_terminals=

which look in mc 4.6.2-pre1 like this:
http://www.esnips.com/doc/fc65cf70-f688-448d-ba45-c6d6dfc1a9bf/mc-dir-menu

then it looks like this in mc 4.7.0.1:
http://www.esnips.com/doc/12bc56c7-953e-493e-8deb-061649b42f1e/mc-dir-menu-4701oldini.

mcedit looks in 4.6.2-pre1 with those colors in ini like this:
http://www.esnips.com/doc/ff64545d-2e9a-40b1-9119-027c8f9ffce8/mc-edit

and like this in mcedit of 4.7.0.1:
http://www.esnips.com/doc/84c1c52f-2c36-4167-b3bf-d7d2ba557a96/mc-edit-4701oldini

Now your reworked darkfar looks in a directory like this:
http://www.esnips.com/doc/8a085ae5-533b-4638-b8c2-f6fc28a9238a/mc-dir-copy-4701frank

Note the copy menu. In 4.6.2-pre1 with my colors that looks like:
http://www.esnips.com/doc/60df64d4-6bab-4837-9537-3b053cd53d8b/mc-dir-copy

But the problem is bigger in mcedit. With the reworked darkfar skin that looks 
like:
http://www.esnips.com/doc/39e00bf7-49bc-4c82-8f00-3abb316abbf6/mc-edit-4701frank

Thanks again.
Hugo










      
_______________________________________________
mc mailing list
http://mail.gnome.org/mailman/listinfo/mc
<Prev in Thread] Current Thread [Next in Thread>