[email protected]
[Top] [All Lists]

Re: mc starts after 60 second delay

Subject: Re: mc starts after 60 second delay
From: Fabian Braennstroem
Date: Thu, 14 Sep 2006 20:19:26 +0200
Hi Lindy,

I had the same problem a while ago, actually I still have,
when I use 'zsh' for shell (it works fine with bash and
tcsh) ... I do not have any clue

* On 14 Sep 2006 * Lindy Mayfield wrote:

> I'm running Ubuntu Linux:
> 
> Linux lian 2.6.15-26-386 #1 PREEMPT Thu Aug 3 02:52:00 UTC 2006 i686 GNU/Linux
> 
> And mc was working fine and one day it just stopped.  I'm quite sure
> it is something I did, but as of yet I haven't found the problem.
> 
> When I start mc there is a 60 second delay before it will start up.
> I've tried many things, from rebooting to reinstalling.  I've played
> around with my DISPLAY which is set to :0.0 right now.  However I
> don't think it is that because I've unset it, and also the delay also
> happens when I ssh into the box with no xwindows.
> 
> The mc version is 1:4.6.1-1ubuntu2.
> 
> Running gdb mc I get:
> 
> (gdb) run
> Starting program: /usr/bin/mc
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> (no debugging symbols found)
> 
> And then it hangs.  Hitting ctrl-c:
> 
> Program received signal SIGINT, Interrupt.
> 0xffffe410 in __kernel_vsyscall ()
> 
> And where:
> 
> (gdb) where
> #0  0xffffe410 in __kernel_vsyscall ()
> #1  0xb7dce88d in poll () from /lib/tls/i686/cmov/libc.so.6
> #2  0xb7ba8647 in __res_queriesmatch () from /lib/tls/i686/cmov/libresolv.so.2
> #3  0xb7ba7113 in __libc_res_nquery () from /lib/tls/i686/cmov/libresolv.so.2
> #4  0xb7ba73d8 in __res_nquery () from /lib/tls/i686/cmov/libresolv.so.2
> #5  0xb7ba7793 in __libc_res_nsearch () from /lib/tls/i686/cmov/libresolv.so.2
> #6  0xb7f9b2be in _nss_dns_gethostbyname3_r () from
> /lib/tls/i686/cmov/libnss_dns.so.2
> #7  0xb7f9b528 in _nss_dns_gethostbyname_r () from
> /lib/tls/i686/cmov/libnss_dns.so.2
> #8  0xb7dedb34 in gethostbyname_r () from /lib/tls/i686/cmov/libc.so.6
> #9  0xb7ded494 in gethostbyname () from /lib/tls/i686/cmov/libc.so.6
> #10 0x080b9801 in ?? ()
> #11 0x0811ab70 in ?? ()
> #12 0xbffbdbc8 in ?? ()
> #13 0xb7de5f68 in inet_addr () from /lib/tls/i686/cmov/libc.so.6
> #14 0x080b9a67 in ?? ()
> #15 0xbffbdc58 in ?? ()
> #16 0x00000001 in ?? ()
> #17 0x00000400 in ?? ()
> #18 0x0811cb08 in ?? ()
> #19 0x0811bf60 in ?? ()
> #20 0x00000002 in ?? ()
> #21 0xbffbdc18 in ?? ()
> #22 0x080b5038 in ?? ()
> #23 0x0811cb08 in ?? ()
> #24 0x080cc7d6 in _IO_stdin_used ()
> #25 0xbffbdcd8 in ?? ()
> #26 0x00000000 in ?? ()
> 
> Is it sitting and waiting for something in poll() in libc.so.6?
> 
> I've been timing it and it is right at 60 seconds each time.  I've
> been trying to figure this out for weeks.  Very frustrating. (-:
> 
> Any ideas about what this could be would be greatly appreciated!
> 
> Kind regards,
> Lindy
> _______________________________________________
> Mc mailing list
> http://mail.gnome.org/mailman/listinfo/mc
> 

-- 
_______________________________________________
Mc mailing list
http://mail.gnome.org/mailman/listinfo/mc

<Prev in Thread] Current Thread [Next in Thread>