macromedia.coldfusion.cfml_general_discussion
[Top] [All Lists]

Problem in calling webservice in Websphere Inegration Developer from web

Subject: Problem in calling webservice in Websphere Inegration Developer from webClient
From:
Date: Sun, 12 Aug 2007 23:07:48 -0700
Newsgroups: macromedia.coldfusion.cfml_general_discussion
Hi,
I'm using Websphere integration developer (WID) with process server
6.0.1.5 to integrate two modules.
Calling of web service works fine within integrated Test Environment
of WID but when I try to access it through web client it gives
following error

I don't know If I have to run endPointEnabler or do some simple
configuration. If some one has already encountered this problem kindly
let me know of a possible way to solve this problem.

Following is error message that I encounter .. any suggestion to solve
this will be appreciated, Tankyou.



[8/12/07 22:36:05:872 PDT] 0000004c EngineConfigu E
com.ibm.ws.webservices.engine.configuration.EngineConfigurationFactoryFinder
$1 run WSWS3345E: Error: Unable to locate a valid
EngineConfigurationFactory.
[8/12/07 22:36:06:059 PDT] 0000004c ServletWrappe E   SRVE0068E: Could
not invoke the service() method on servlet
WSCreditRequest_CreditRequestHttpPort. Exception thrown :
javax.servlet.ServletException: WSWS3142E: Error: Could not find Web
services engine.
        at
com.ibm.ws.webservices.engine.transport.http.WebServicesServlet.doPost(WebServicesServlet.java:
620)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
        at
com.ibm.ws.webservices.engine.transport.http.WebServicesServletBase.service(WebServicesServletBase.java:
341)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
        at
com.ibm.ws.webcontainer.servlet.ServletWrapper.service(ServletWrapper.java:
1572)
        at
com.ibm.ws.webcontainer.servlet.ServletWrapper.handleRequest(ServletWrapper.java:
762)
        at com.ibm.ws.webcontainer.webapp.WebApp.handleRequest(WebApp.java:
3071)
        at
com.ibm.ws.webcontainer.webapp.WebGroup.handleRequest(WebGroup.java:
236)
        at com.ibm.ws.webcontainer.VirtualHost.handleRequest(VirtualHost.java:
210)
        at
com.ibm.ws.webcontainer.WebContainer.handleRequest(WebContainer.java:
1958)
        at
com.ibm.ws.webcontainer.channel.WCChannelLink.ready(WCChannelLink.java:
109)
        at
com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleDiscrimination(HttpInboundLink.java:
472)
        at
com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.handleNewInformation(HttpInboundLink.java:
411)
        at
com.ibm.ws.http.channel.inbound.impl.HttpInboundLink.ready(HttpInboundLink.java:
288)
        at
com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminaters(NewConnectionInitialReadCallback.java:
207)
        at
com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:
109)
        at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.requestComplete(WorkQueueManager.java:
566)
        at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.attemptIO(WorkQueueManager.java:
619)
        at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.workerRun(WorkQueueManager.java:
952)
        at com.ibm.ws.tcp.channel.impl.WorkQueueManager
$Worker.run(WorkQueueManager.java:1039)
        at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java(Compiled
Code))


<Prev in Thread] Current Thread [Next in Thread>
  • Problem in calling webservice in Websphere Inegration Developer from webClient, Seaps16 <=