macromedia.coldfusion.cfml_general_discussion
[Top] [All Lists]

Problem when consuming web service on WIndows authentication applcation

Subject: Problem when consuming web service on WIndows authentication applcation
From: "Sandeepjain13"
Date: Sat, 25 Aug 2007 05:12:59 +0000 UTC
Newsgroups: macromedia.coldfusion.cfml_general_discussion
Hi,

 I am having a tough time in consuming web services on a Windows authentication 
IIS server.

 In one of my application I have created web services and consuming those web 
services from my another application.

 If I turned off the Windows authentication everything works fine, but If I 
turned on the Windows authentication web services stop working.

 Has anyone encountered such error while working with web services on Windows 
authentication server.

 Attach Code

 Could not perform web service invocation "funGetCustomer". 
 Here is the fault returned when invoking the web service operation:

 AxisFault
 faultCode: {http://xml.apache.org/axis/}HTTP
 faultSubcode: 
 faultString: (401)Unauthorized
 faultActor: 
 faultNode: 
 faultDetail: 
 {}:return code: 401
 <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" 
"http://www.w3.org/TR/html4/strict.dtd";>
 <HTML><HEAD><TITLE>You are not authorized to view this page</TITLE>
 <META HTTP-EQUIV="Content-Type" Content="text/html; charset=Windows-1252">
 <STYLE type="text/css">
 BODY { font: 8pt/12pt verdana }
 H1 { font: 13pt/15pt verdana }
 H2 { font: 8pt/12pt verdana }
 A:link { color: red }
 A:visited { color: maroon }
 </STYLE>
 </HEAD><BODY><TABLE width=500 border=0 cellspacing=10><TR><TD>

 <h1>You are not authorized to view this page</h1>
 You do not have permission to view this directory or page using the 
credentials that you supplied because your Web browser is sending a 
WWW-Authenticate header fi... 


<Prev in Thread] Current Thread [Next in Thread>
  • Problem when consuming web service on WIndows authentication applcation, Sandeepjain13 <=