laptop-discuss@opensolaris.org
[Top] [All Lists]

Re: [laptop-discuss] Wireless Network Driver for Realtek 8180 802.11b Ch

Subject: Re: [laptop-discuss] Wireless Network Driver for Realtek 8180 802.11b Chipset rtw
From: James Cornell
Date: Fri, 07 Mar 2008 03:23:09 -0600
taoww wutao wrote:
> Hi,James
> More infomation are attached.
>
> Thanks,
>
> Tao
> --- James Cornell <sparcdr@xxxxxxxxxxx> wrote:
>
>   
>> Tao Wu wrote:
>>     
>>> I used Netgear MA521 on my notebook.The OS is
>>>       
>> snv_79b.
>>     
>>> The card is detected and driver attached, but no
>>>       
>> signal,not scan any
>>     
>>> wireless network.Why?
>>>
>>> Thank you!
>>>  
>>>  
>>> This message posted from opensolaris.org
>>> _______________________________________________
>>> laptop-discuss mailing list
>>> laptop-discuss@xxxxxxxxxxxxxxx
>>>   
>>>       
>> More information is needed, could you run prtconf
>> -pv, modinfo, and 
>> /usr/X11/bin/scanpci -v to give us more details
>> about what specific card 
>> you're using?
>>
>> James
>>
>>     
Funny, I was about to buy one very similar, but I ended up not needing a 
wireless card for my desktop as the cable was setup in my room.  
Anyways, I tried looking around on bugs.opensolaris.org for anything 
related to "rtw" (Actual module name) and "realtek" but apparently 
there's not much on it.  I can't seem to find any fix either, at least 
not yet, Michael Li replied to this, it's with the device interrupts.

This is way to low-level for me to explain correctly, as this is really 
not what I specialize in.  In a nutshell though, something is lost in 
translation, the device and pcmcia controller are not sending key data, 
either correctly, or at all.  Hence it cannot scan and probably wouldn't 
associate if you tried forcing it.  Again, don't call me an expert, I 
mostly repeat what others have done, this stuff is usually NDA or 
reverse engineered, and quite specialized to fix.  I am wondering what 
is up with the garbage ACPI debug info. doubtful this is the root cause.

James
_______________________________________________
laptop-discuss mailing list
laptop-discuss@xxxxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>