kde-core-devel@kde.org
[Top] [All Lists]

Re: ANNOUNCE: CMake 2.4.5 will be required starting Monday, March 19th

Subject: Re: ANNOUNCE: CMake 2.4.5 will be required starting Monday, March 19th
From: Cyrille Berger
Date: Sun, 11 Mar 2007 23:40:53 +0100
On Sunday 11 March 2007, Alexander Neundorf wrote:
> But there also weren't major objections to requiring 2.4.5, so I got the
> impression most people already have >= 2.4.5.

Yes but no. From the other thread, not only, I got the impression there was an 
objection to the continuous uping of requirements, but quiet a lot of stable 
version of the major distributions don't have cmake 2.4.5. And it's not that 
this is difficult to increase version, but it's time consuming and not at all 
fun. I doubt that I am the only developers to like working with a stable 
environnement, and by stable, I don't mean not crashing, krita crashes more 
because of us than kdelibs, but by stable I mean I can safely "svn up" and 
not spend two hours downloading new programs, upgrading other libraries, 
etc... etc... And sure cmake is less a dangerous upgrade than dbus or Qt4, 
but still it's annoying.

So please, at least wait for Qt 4.3 to be forced upon us before upping the 
requirement of cmake. (maybe a policy for waiting every first monday of a 
month before upping the requirement would have been a nice idea, lets keep 
that in mind for KDE5 ;) )

-- 
Cyrille Berger

<Prev in Thread] Current Thread [Next in Thread>