On Thursday 15 March 2007 18:05, Aaron J. Seigo wrote:
> so i'd like to suggest that when such a need arrises that we have a
> standard, and suitably ugly, naming convention for them so it is
> immediately recognizable as such a method. specifically, i'd like to make
> this is the standard naming notation for such methods:
> they should reside in their own protected: block away from other normal
> methods just to make it even more obvious when reading headers.
Why not just mark them as internal in the API documentation? Giving them ugly
names makes the code legitimately using them ugly as well. Is this worth the
little additional security against people using them accidently?
Cornelius Schumacher <[email protected]>