Am Sonntag, 18. MÃrz 2007 07:04:31 schrieb Aaron J. Seigo:
> > * addDocCollection
> > a)huh?, b) used in one case in KHelpCenter. Can't be that useful.
> looking at the code, it seems that the intention is to make it so that you
> can load a document with associated actions and add those actions to the
> application. however, if the application already has an action by the same
> name, then the app's action masks the doc's action. essentially, this seems
> to allow a doc to add unique actions to the view without clobbering the
> view's actions in the process.
> sounds reasonable to me. that it's used only once makes it a bit odd to
> have that feature in kdelibs, but it does seem like the most elegant place
> for it.
I did read the code, too. Yes, I probably dislike the name more than the
Let's rename it to addOverlayCollection(*) - that way, no confusion when
reading the documentation and people that need this function *will actually
find and use it*. It goes without saying that the documentation needs to be
(*) Mechanism, not policy, as they say. Document what it can do, not how you
are supposed to use it.