Alexander Neundorf wrote:
>If it is possible to work on KDE with the software as it comes with your
>distro the entry barrier to development is much lower.
This "entry barrier" only exists as such because the distros *are*
shipping cmake. If they weren't, nobody would be complaining that you
need a newer version.
I still see it as artificial. Why can't we require people to install the
newest CMake if they are building software that is hundreds of times more
complex? If you can get Qt and kdelibs to build, you can get CMake too.
This is the second time in as many months that you have had to intervene
because someone unknowingly used a CMake >= 2.4.4 feature. If we are
going to stay with 2.4.3, we should start then requiring that people use
*exactly* 2.4.3, so as to avoid this kind of mistakes.
>And, maybe most important, if we require a newer version of CMake, this
> needs to be brought up on k-c-d or k-b-s ;-) and then announced with at
> least one week warning period.
>And the required version in FindKDE4Internal.cmake HAS to be adjusted
So what's stopping us from making that announcement now?
If you want an announcement for Qt 4.3: the qt-x11-4 snapshot switched
yesterday to Qt 4.3.0, which means the beta release will happen within
the next few weeks. Does this count as the announcement that we will
require Qt 4.3.0 beta 1 when it is out?
Thiago Macieira - thiago (AT) macieira.info - thiago (AT) kde.org
PGP/GPG: 0x6EF45358; fingerprint:
E067 918B B660 DBD1 105C 966C 33F5 F005 6EF4 5358