javasf@googlegroups.com
[Top] [All Lists]

Re: [javasf] [OFF-TOPIC] Win 7 64 bit e Eclipse Helios

Subject: Re: [javasf] [OFF-TOPIC] Win 7 64 bit e Eclipse Helios
From: David Faulstich
Date: Mon, 30 May 2011 19:11:55 -0300
Eu pessoalmente retiro todas as validações dos projetos. Eu acho que isto só serve para "lerdar" o eclipse.

O suporte do MAVEN também acho complicado pois dependendo que seus repositórios, demora demais para iniciar.

Quais plugins você utiliza e quanto de memória tem seu computador.

Meu notebook é um Dell com 3gb de RAM core2duo 2ghz. Acho lerdo mais consigo rodar de boa. Meu eclipse.ini está abaixo:
-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1.R36x_v20100810
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
768M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
768m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms100m
-Xmx1536m

----
Uso eclipse + SVN + jboss tools.

Lembrando, eu desabilito tudo que é validação. Para mim não serve para nada.

Em 30 de maio de 2011 09:43, Arthur "Arcanjoyue" Ferreira <arcanjoyue@xxxxxxxxx> escreveu:
Falae galera,

Eu to com um problema que eu queria saber se mais alguém está tendo. Pesquisei no Google e não encontrei nada, mas pode ser que alguns de vocês tenham passado por algo parecido.

Eu uso Win 7 64 bit lá em casa e peguei o Eclipse Helios (64 bit também), assim como a JDK 64 bit.

O problema que tá rolando é que ele têm dado umas travadas e lentidão absurdas. Isso acontece principalmente quando o validator de código está rodando, mas acontece também na hora de acessar o repositório de update sites. O primeiro caso é o mais sério porque quando eu preciso compilar o projeto, ele fica lá esperando o validator terminar e isso nunca acontece. Pior ainda é quando estou com um projeto rodando no servidor local e ele não faz hot-deploy por causa do mesmo motivo! Aí você perde a paciência e tenta reiniciar o Eclipse. Aí eu percebi que, mesmo fechando o eclipse, o java.exe continua executando na minha lista de tarefas do windows. Enquanto eu não finalizar essa tarefa, mesmo que eu abra de novo o Eclipse o problema com o validator vai continuar. E, mesmo finalizando a tarefa, ele depois de pouco tempo volta a dar esse problema de novo.

Eu tava pensando em desinstalar tudo que fosse de 64bit e instalar tudo de 32bit para ver se não é esse o problema...

Alguém já passou por isso ou coisa parecida? Ou alguém tem alguma sugestão?

Abraços,

Arthur Franco Ferreira
Analista Desenvolvedor Web Java Pleno
Licenciado em Computação
UNILASALLE-RJ


--
Você recebeu esta mensagem por que é membro do Javasf
http://groups.google.com/group/javasf
 
Conheça também o Java Brazil: http://groups.google.com/group/thejavabrazil

--
Você recebeu esta mensagem por que é membro do Javasf
http://groups.google.com/group/javasf
 
Conheça também o Java Brazil: http://groups.google.com/group/thejavabrazil
<Prev in Thread] Current Thread [Next in Thread>