j-dev@xerces.apache.org
[Top] [All Lists]

Build with Harmony (WAS: Xerces-J compilation error)

Subject: Build with Harmony WAS: Xerces-J compilation error
From: "Nathan Beyer"
Date: Wed, 23 Jul 2008 21:34:54 -0500
I'm attempting to run the build scripts with Harmony. What's the expected building convention? What JDK is normally used, is the build.bat/sh script used, or is Ant invoked directly? What version of Ant is known to work.

In looking at the build.bat script, it seems like it won't work for Sun's JDK 6, as there isn't a 'classes.zip' in the JDK_HOME/lib folder.

-Nathan

On Sun, Jul 20, 2008 at 9:24 PM, Nathan Beyer <ndbeyer@xxxxxxxxxx> wrote:
I haven't tried it myself. I'll try to give it a shot and see what happens.

Thanks for the notice about the JAXP update. Will Xerces start compiling at a higher source or target level as well? Isn't the code still at 1.3 source/target level? What about library level?


On Sat, Jul 19, 2008 at 11:46 PM, Michael Glavassevich <mrglavas@xxxxxxxxxx> wrote:

Hi Nathan,

Out of curiousity does Xerces Ant build work with Harmony? I've never downloaded a build before so haven't tried it myself.

Also an FYI for the Harmony community ... Xerces-J 2.9.1 is the final release that would be at the Java 5 level (JAXP 1.3). We recently updated to the JAXP 1.4 APIs on the trunk. This is the JAXP level in Java 6.


Thanks.

Michael Glavassevich
XML Parser Development
IBM Toronto Lab
E-mail: mrglavas@xxxxxxxxxx

E-mail: mrglavas@xxxxxxxxxx

nbeyer@xxxxxxxxx wrote on 07/20/2008 12:23:47 AM:


> Another option would be to remove the JRE class library and use a
> subset of the JARs from the latest Harmony build [1].
>
> [1] http://harmony.apache.org/


<Prev in Thread] Current Thread [Next in Thread>