help-cfengine@gnu.org
[Top] [All Lists]

Re: email notification problem

Subject: Re: email notification problem
From:
Date: 11 Mar 2006 10:07:56 -0800
Newsgroups: gnu.cfengine.help
Hi Jason,

Thanks for responding to help me during my cfengine break-in period...
:)   My splaytime is set to 0, but check this out:

% cfagent -q -I

!: Error while trying to link /etc/rc2.d/S97cfservd ->
/etc/init.d/cfservd
!: Error while trying to link /etc/rc2.d/S97cfenvd ->
/etc/init.d/cfenvd
!: Error while trying to link /etc/rc1.d/K50cfservd ->
/etc/init.d/cfservd
!: Error while trying to link /etc/rc1.d/K50cfenvd ->
/etc/init.d/cfenvd
!: Tidy directory /etc/dmi/conf cannot be accessed

OK, so I see output, and would love this kind of stuff to be emailed to
me.  So when I run cfexecd in debug mode (I substituted hostnames and
domainnames to myhost.domain.com, etc, but everything else is the
same):

% cfexecd -q -F --debug

cfexecd Debug mode: running in foreground
Directory for /var/cfengine/inputs/update.conf exists. Okay
Directory for /var/cfengine/bin/cfagent -D from_cfexecd exists. Okay
Directory for /var/cfengine/outputs/spooled_reports exists. Okay
cfpopen(/var/cfengine/bin/cfagent -Q
smtpserver,sysadm,fqhost,host,domain,ipaddress,EmailMaxLines,EmailFrom,EmailTo
-D from_cfexecd)
smtpserver/mail.mydomain.com
sysadm=me@xxxxxxxxxx
fqhost/myhost.domain.com
host/myhost
domain/domain.com
ipaddress/122.122.122.122
EmailMaxLines/100
EmailFrom/$(EmailFrom)
EmailTo/$(EmailTo)
EmailTo/$(EmailTo)
cfpclose(pp)
cfpopen - Waiting for process 28895
Got(to:me@xxxxxxxxxx,serv:mail.domain.com,fqhost:myhost.domain.com,host:myhost,domain:domain.com,ip:122.122.122.122,max:100,from:)
cfpopen(/var/cfengine/bin/cfagent -z -D from_cfexecd)
cfpclose(pp)
cfpopen - Waiting for process 28906
No schedule defined in cfagent.conf, defaulting to Min00_05
Appending [Min00_05]
---------------------------------------------------------------------
Starting server
---------------------------------------------------------------------

cfpopen(/var/cfengine/bin/cfagent -Q
smtpserver,sysadm,fqhost,host,domain,ipaddress,EmailMaxLines,EmailFrom,EmailTo
-D from_cfexecd)
smtpserver/mail.domain.com
sysadm=me@xxxxxxxxxx
fqhost/myhost.domain.com
host/myhost
domain/domain.com
ipaddress/122.122.122.122
EmailMaxLines/100
EmailFrom/$(EmailFrom)
EmailTo/$(EmailTo)
EmailTo/$(EmailTo)
cfpclose(pp)
cfpopen - Waiting for process 28917
Got(to:me@xxxxxxxxxx,serv:mail.domain.com,fqhost:myhost.domain.com,host:myhost,domain:domain.com,ip:122.122.122.122,max:100,from:)
cfpopen(/var/cfengine/bin/cfagent -z -D from_cfexecd)
cfpclose(pp)
cfpopen - Waiting for process 28928
No schedule defined in cfagent.conf, defaulting to Min00_05
Appending [Min00_05]
------------------------------------------------------------------

  LocalExec(not scheduled) at Sat Mar 11 09:38:20 2006

------------------------------------------------------------------
cfpopen(/var/cfengine/bin/cfagent -q -Dfrom_cfexecd)
cfpclose(pp)
cfpopen - Waiting for process 28939
Closing fp
Nothing to report in
/var/cfengine/outputs/cf_myhost_domain_com_2006-03-11--09-38-20

**************************

It says "Nothing to report" at the bottom which is bogus, and it
worries me.  It seems to go through the cfpopen stuff twice..  Not sure
if that means anything...  Or maybe it's not generating the output that
'cfagent -I' usually generates?

cheers,
erich

_______________________________________________
Help-cfengine mailing list
Help-cfengine@xxxxxxx
http://lists.gnu.org/mailman/listinfo/help-cfengine

<Prev in Thread] Current Thread [Next in Thread>