download binary distribution for ghc-6.12.1,
configure, sudo make install - fine
try to build some packages: cabal configure ...:
cabal: This version of the cabal program is too old to work with ghc-6.12+.
You will need to install the 'cabal-install' package version 0.8 or higher.
If you still have an older ghc installed (eg 6.10.4), run:
$ cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
Right - looks like a very useful error message! Then let's do it:
cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
cabal: There is no available version of cabal-install that satisfies >=0.8
Indeed, a package with that version does not seem to exist.
darcs get --partial http://darcs.haskell.org/cabal-install/
It says 0.7.5, but let's try anyway:
sudo ./bootstrap.sh --global
Error during cabal-install bootstrap:
The Haskell package 'network' is required but it is not installed.
Aha. Then let's get network from hackage, as in the olden days.
And parsec. And mtl. And bytesting. And syb. Well, let's try
to use "cabal fetch" to avoid at least some typing.
But no, cabal ist too old for 6.12 -
and "cabal fetch" does not understand "-w ghc-6.10.4"
Manually download HTTP and zlib, and then cabal-install
really builds. Great. Try to use it to build some packages,
which finally breaks at derive-2.0.1 -
but it seems this page is going to be helpful (thanks, guys):
anyway I'm stopped now because somewhere along the way this happened:
[email protected]:~/software/haskell/ghc-syb$ ghc-pkg check
There are problems in package ghc-binary-0.5.0.2:
best - J.W.
Haskell-Cafe mailing list