[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] cabal install glfw

Subject: Re: [Haskell-cafe] cabal install glfw
From: Ozgur Akgun
Date: Wed, 20 Jan 2010 11:16:56 +0000
Sorry, I cannot install GHC 6.12 right now, so I won't be able to try it. Thanks anyway.

2010/1/19 Paul L <[email protected]>
The problem you mentioned has long been fixed in the darcs version,
but then there is also another problem: you need GHC 6.12 in order to
compile GLFW for Snow Leopard. Here is a detail description of why
prior versions of GHC fails to work:
http://hackage.haskell.org/trac/ghc/ticket/3522

I've just made a new release and bumped GLFW to 0.4.2, you may try it
with GHC 6.12 on Snow Leopard and see if it now works.


On 1/19/10, Ozgur Akgun <[email protected]> wrote:
> Dear Cafe and Paul,
>
> I am constantly having problems with cabal install in Snow Leopard. Some I
> solve, some I cannot unfortunately.
>
> When I run
>
> sudo cabal install glfw -v2
>
> in Snow Leopard, I get the following.
>
> glfw/lib/macosx/macosx_enable.c:1:0:
> Â Â Âerror: bad value (apple) for -march= switch
>
> glfw/lib/macosx/macosx_enable.c:1:0:
> Â Â Âerror: bad value (apple) for -mtune= switch
> cabal: Error: some packages failed to install:
> GLFW-0.4.1 failed during the building phase. The exception was:
> exit: ExitFailure 1
>
>
> Regards,
>
> --
> Ozgur Akgun
>


--
Regards,
Paul Liu

Yale Haskell Group
http://www.haskell.org/yale



--
Ozgur Akgun
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe
<Prev in Thread] Current Thread [Next in Thread>