[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] Failing to install hxt

Subject: Re: [Haskell-cafe] Failing to install hxt
From: ""
Date: Sun, 24 Jan 2010 00:38:44 +0100 CET

Don Stewart <[email protected]> hat am 24. Januar 2010 um 00:10 geschrieben:

> haskell:
> > > Looks like the author of hxt has decided to support 6.12 only, at the
> > > moment.
> > >
> > >     base (>=4.2 && <5)
> > >
> > > Ensures this will only work on the 6.12 series of compilers.
> >
> > Thanks. I know.
> >
> > My point is, i don't understand why hxt-8.3.2 (base >= 4 && <5) fails to
> > install for me with:
> >
> > "
> > src/Text/XML/HXT/Parser/TagSoup.hs:292:8:
> >     Not in scope: `optLookupEntity'
> > cabal: Error: some packages failed to install:
> > hxt-8.3.2 failed during the building phase. The exception was:
> > exit: ExitFailure 1
> > "
>
> That looks like an error relating to the versoin of tagsoup used?

You're right, thanks.
"optLookupEntity" is defined in tagsoup-0.6, but not in tagsoup-0.8.
But hxt-8.3.2 broadly requires tagsoup (>=0.6 && <1).

I am no cabal expert. What is the best solution here?
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe
<Prev in Thread] Current Thread [Next in Thread>