[email protected]
[Top] [All Lists]

[Haskell-cafe] xmonad cannot find its library after upgrading GHC

Subject: [Haskell-cafe] xmonad cannot find its library after upgrading GHC
From: zaxis
Date: Sun, 17 Jan 2010 20:13:50 -0800 PST
After `pacman -Syu`, the ghc is upgraded to 6.12.1
%ghc --version
The Glorious Glasgow Haskell Compilation System, version 6.12.1

However, the xmonad still stay as it is:
%pacman -Q|grep -i xmonad
xmonad 0.9-2.1
xmonad-contrib 0.9-1.2

%pacman -Ql xmonad|more 
......
xmonad /usr/lib/ghc-6.10.4/
xmonad /usr/lib/ghc-6.10.4/site-local/
xmonad /usr/lib/ghc-6.10.4/site-local/xmonad-0.9/
xmonad /usr/lib/ghc-6.10.4/site-local/xmonad-0.9/HSxmonad-0.9.o
xmonad /usr/lib/ghc-6.10.4/site-local/xmonad-0.9/XMonad.hi
xmonad /usr/lib/ghc-6.10.4/site-local/xmonad-0.9/XMonad/
.....

So it will fail when running `xmonad --recompile` as xmonad cannot find its
library in /usr/lib/ghc-6.12.1.
Do i need to re-install xmonad ?

Sincerely!

-----
fac n = foldr (*) 1 [1..n]
-- 
View this message in context: 
http://old.nabble.com/xmonad-cannot-find-its-library-after-upgrading-GHC-tp27206013p27206013.html
Sent from the Haskell - Haskell-Cafe mailing list archive at Nabble.com.

_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>