[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] Cabal bug?

Subject: Re: [Haskell-cafe] Cabal bug?
From: Ivan Lazar Miljenovic
Date: Mon, 11 Jan 2010 22:54:20 +1000
"Henk-Jan van Tuyl" <[email protected]x> writes:

> I had a strange response from Cabal:
>   >cabal upgrade hlint

I thought upgrade was disabled... what version of cabal-install do you have?

>   Resolving dependencies...
>   cabal: cannot configure containers-0.3.0.0. It requires base >=4.2 && <6
>   For the dependency on base >=4.2 && <6 there are these packages:
> base-4.2.0.0.

Base 4.2 and containers-0.3 come with/are for GHC-6.12.*

> So, base-4.2.0.0 cannot be used, because any version of base is OK? Is
> this a bug in Cabal?

The latest version of hlint doesn't need containers-0.3; so just do
"cabal install --reinstall hlint" to get the new version.

-- 
Ivan Lazar Miljenovic
[email protected]
IvanMiljenovic.wordpress.com
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>