"Henk-Jan van Tuyl" <[email protected]x> writes:
> I had a strange response from Cabal:
> >cabal upgrade hlint
I thought upgrade was disabled... what version of cabal-install do you have?
> Resolving dependencies...
> cabal: cannot configure containers-0.3.0.0. It requires base >=4.2 && <6
> For the dependency on base >=4.2 && <6 there are these packages:
Base 4.2 and containers-0.3 come with/are for GHC-6.12.*
> So, base-188.8.131.52 cannot be used, because any version of base is OK? Is
> this a bug in Cabal?
The latest version of hlint doesn't need containers-0.3; so just do
"cabal install --reinstall hlint" to get the new version.
Ivan Lazar Miljenovic
Haskell-Cafe mailing list