haskell-cafe@haskell.org
[Top] [All Lists]

Re: [Haskell-cafe] Problem with cabal install zlib

Subject: Re: [Haskell-cafe] Problem with cabal install zlib
From: Max Cantor
Date: Sat, 19 Dec 2009 18:32:13 +0800
I actually ran into this problem last night.  Here's my workaround (note that 
it involves downgrading to zlib-0.5.0.0

1) unregister the zlib-0.5.2.0 package (prompt> ghc-pkg unregister zlib-0.5.2.0)
2) rebuild and install cabal-install:
        prompt> tar -zxvf 
~/.cabal/packages/hackage.haskell.org/cabal-install/0.6.4/cabal-install-0.6.4.tar.gz
        prompt> cd cabal-install-0.6.4
        prompt> runghc Setup.hs configure --user && runghc Setup.hs build && 
runghc Setup.hs install

Note that this requires that you still have zlib-0.5.0.0 installed.  Also your 
paths and options for configuring may vary.  But, this worked for me.

Max

On Dec 19, 2009, at 5:39 PM, Ozgur Akgun wrote:

> Thanks for the feedback.
> 
> I guess the following part is the problematic part: (But I've no idea how to 
> resolve it)
> 
> Creating dist/build (and its parents)
> Creating dist/build/autogen (and its parents)
> Preprocessing library zlib-0.5.2.0...
> Creating dist/build/Codec/Compression/Zlib (and its parents)
> /usr/bin/hsc2hs --cc=/usr/bin/gcc --ld=/usr/bin/gcc 
> --cflag=-D__GLASGOW_HASKELL__=610 --lflag=-lz 
> --cflag=-I/Users/ozgurakgun/.cabal/lib/bytestring-0.9.1.5/ghc-6.10.4/include 
> --cflag=-I/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-4.1.0.0/include
>  
> --cflag=-I/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/include
>  --lflag=-L/Users/ozgurakgun/.cabal/lib/bytestring-0.9.1.5/ghc-6.10.4 
> --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-3.0.3.1
>  
> --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/syb-0.1.0.1
>  
> --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/base-4.1.0.0
>  
> --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/integer-0.1.0.1
>  
> --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4/ghc-prim-0.1.0.0
>  --lflag=-L/Library/Frameworks/GHC.framework/Versions/610/usr/lib/ghc-6.10.4 
> --lflag=-lm --lflag=-lffi --lflag=-lgmp --lflag=-ldl -o 
> dist/build/Codec/Compression/Zlib/Stream.hs Codec/Compression/Zlib/Stream.hsc
> Only one output file may be specified
> cabal: Error: some packages failed to install:
> zlib-0.5.2.0 failed during the building phase. The exception was:
> exit: ExitFailure 1
> 
> 
> 2009/12/19 Duncan Coutts <duncan.coutts@xxxxxxxxxxxxxx>
> On Fri, 2009-12-18 at 23:01 +0000, Ozgur Akgun wrote:
> > Hi,
> >
> > When I run cabal install zlib or cabal upgrade zlib I get the
> > following error:
> >
> > Resolving dependencies...
> > Configuring zlib-0.5.2.0...
> > Preprocessing library zlib-0.5.2.0...
> > Only one output file may be specified
> 
> We'll need more details here. Try running with -v2 or -v3. It should say
> what command it's running.
> 
> Duncan
> 
> 
> 
> 
> -- 
> Ozgur Akgun
> _______________________________________________
> Haskell-Cafe mailing list
> Haskell-Cafe@xxxxxxxxxxx
> http://www.haskell.org/mailman/listinfo/haskell-cafe

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe@xxxxxxxxxxx
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>