[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] Configuring cabal install readline on Snow Leopard wi

Subject: Re: [Haskell-cafe] Configuring cabal install readline on Snow Leopard with MacPorts
From: Judah Jacobson
Date: Tue, 29 Dec 2009 00:14:33 -0800
On Mon, Dec 28, 2009 at 11:48 PM, Alexy Khrabrov <[email protected]> wrote:
> I've tried to do cabal install readline on Snow Leopard with MacPorts and it 
> fails with the infamous:
>
> $ cabal install readline
> ...
> checking for GNUreadline.framework... checking for readline... no
> checking for tputs in -lncurses... yes
> checking for readline in -lreadline... yes
> checking for rl_readline_version... yes
> checking for rl_begin_undo_group... no
> configure: error: readline not found, so this package cannot be built
> See `config.log' for more details.
> cabal: Error: some packages failed to install:
> readline-1.0.1.0 failed during the configure step. The exception was:
> exit: ExitFailure 1
>
> Googilng shows the usual explanation that Mac'y broken clone interferes; yet 
> I do have MacPorts and readline 6 there.  So I try, per fixes recommended,
>
> $ cabal install readline --extra-include-dirs=/opt/local/include 
> --extra-lib-dirs=/opt/local/lib
> ...
> checking for rl_readline_version... yes
> checking for rl_begin_undo_group... no
> ...
> -- same result.
>
> Downloaded the package and do configure manually:
>
>  ./configure --with-readline-includes=/opt/local/include 
> --with-readline-libraries=/opt/local/lib

You should use:

cabal install readline
--configure-option=--with-readline-includes=/opt/local/include
--configure-option=--with-readline-libraries=/opt/local/lib

Hope that helps,
-Judah
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>