[email protected]
[Top] [All Lists]

[Haskell-cafe] problems installing ghc-6.12.1-x86_64

Subject: [Haskell-cafe] problems installing ghc-6.12.1-x86_64
From: Andrew Polonsky
Date: Thu, 21 Jan 2010 18:12:57 +0100
Dear all,

Help!!  I am trying to build 6.12 on a fresh 64-bit Ubuntu, with no
GHC installed yet.  The compiler itself builds happily, but when I try
to "make install" the Haskell platform, I eventually get the error

Setup: GLUT-2.1.1.2: dependency
"OpenGL-2.2.1.1-b638210d1627880d532e3b035b53bcd2" doesn't exist (use --force
to override)

I can't even install cabal, because it requires having the ghc6
package, which is not installed.  And bootstrapping cabal-install
requires parsec and network, which also require ghc6.

When I finally install ghc6 (why should I have to anyway?), it still
thinks I am on 6.12, and ./bootstrap.sh can't find parsec with that
number.

Is there anyway to break out of this non-terminating reduction?  Is YI
solvable?  :'"(

Andrew
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>