[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] Failing to install hxt

Subject: Re: [Haskell-cafe] Failing to install hxt
From: Don Stewart
Date: Sat, 23 Jan 2010 15:01:44 -0800
haskell:
> Hi guys,
> 
> i have some troubles to install hxt.
> 
> My first naive attempt "cabal install hxt" fails with
> "cabal: cannot configure hxt-8.5.0. It requires base >=4.2 && <5".
> 
> I guess that's because i use ghc 6.10.4, since
> "base-4.2.0.0" depends on "integer-simple" which seems to only come with ghc
> 6.12.

Looks like the author of hxt has decided to support 6.12 only, at the
moment.

    base (>=4.2 && <5)

Ensures this will only work on the 6.12 series of compilers.

-- Don
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>