On 18 Dec 2009, at 06:39, Richard O'Keefe wrote:
My experience has been that in order to make sense of someone else's
code you *HAVE* to break identifiers into their component words.
With names like (real example) ScatterColorPresetEditor, the eye
*can't* take it in at once, and telling the difference between that
and ScatterColorPresentEditor would be a pain. Break them up
Ada-style as Scatter_Colour_Preset_Editor and
Scatter_Colour_Present_Editor and you're away laughing.
Wouldn't it be something like
Editor (Preset (Color Scatter))
Haskell-Cafe mailing list