[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] hsql won't install due to system.time

Subject: Re: [Haskell-cafe] hsql won't install due to system.time
From: Brian Denheyer
Date: Thu, 21 Jan 2010 22:43:40 -0800
On Thu, 21 Jan 2010 09:01:01 +0000
Malcolm Wallace <[email protected]> wrote:

> The easiest workaround is to change your local copy of the .cabal
> file for hsql, modifying the build-depends line to make a more
> precise dependency on old-time, e.g.
>      build-depends: old-time-1.0.0.2

First of all, apologies are in order, the package I am having trouble
with is haskelldb-hsql-sqlite3.  hsql installed just fine, as well as
hsql-sqlite3.

In all of the hackage database package excitement I got confused.

Here's what I tried :

add old-time-1.0.0.2 to the _end_ of the build-depends line:

cabal: haskelldb-hsql-sqlite3.cabal:7: Parse of field 'build-depends'
failed.

Interestingly, if I simply add

  old-time

then I don't get that error but instead my good friend the "hidden
package" error.  I tried giving it it's own build-depends line, but
adding the version suffix still gives me the parse error.

??

Brian
_______________________________________________
Haskell-Cafe mailing list
[email protected]
http://www.haskell.org/mailman/listinfo/haskell-cafe

<Prev in Thread] Current Thread [Next in Thread>