[email protected]
[Top] [All Lists]

Re: [Haskell-cafe] problems with HOC install from svn

Subject: Re: [Haskell-cafe] problems with HOC install from svn
From: Ross Mellgren
Date: Tue, 8 Sep 2009 20:35:54 -0400
It sounds like it's looking for the binary package -- you should install it using cabal, e.g.

private (per-user) install:
cabal update
cabal install binary

global (system-wide) install:
sudo cabal update
sudo cabal install --global binary


On Sep 8, 2009, at 7:57 PM, John Velman wrote:

I'm unable to build HOC from the svn read-only checkout. Here are some
details of what I'm doing.

I'm running OS X 10.5.8 on an intel iMac with Xcode is 3.1.3.

Haskel and Cabal are from the Haskel platform,

I got Parsec 3.0 from Hackage.

I checked out HOC using the svn command at

and checked out revision 411.

Configure goes OK except for the complaint:
   Warning: In the use of `defaultUserHooks'
            (imported from Distribution.Simple):
Deprecated: "Use simpleUserHooks or autoconfUserHooks, unless you need Cabal-1.2 compatibility in which case you must stick with defaultUserHooks"

But when I try to build, I get, after a bunch of apparently successful
Loading package binary- ... <command line>: can't load .so/.DLL for: HSbinary- (dlopen (libHSbinary-, 9): image not found)

I certainly can't find libHSbinary... of any version on my computer, dylib or not. Tried looking in the /Library/Frameworks/GHC.Framework stuff, also did a find . -iname "*libHS* and found libHSGLFW..., libHSparsec-3.0.0.

(also tried this in my home directory).

What is this, and how do I get it?


John Velman

Haskell-Cafe mailing list
[email protected]

Haskell-Cafe mailing list
[email protected]

<Prev in Thread] Current Thread [Next in Thread>