gnu.emacs.bug
[Top] [All Lists]

Re: strange Emacs 22.1 failure due to utf-8-compose-scripts when --no-wi

Subject: Re: strange Emacs 22.1 failure due to utf-8-compose-scripts when --no-window-system used
From: Joe Wells
Date: 10 Jul 2007 17:21:56 -0400
Newsgroups: gnu.emacs.bug

Can anyone else reproduce the problem I describe below?

Joe

Joe Wells <jbw@xxxxxxxxxxxxx> writes:

> Dear Emacs gurus
> Run the script below to see an interesting failure.  These 3
> ingredients are needed:
>
> 1. The environment variable LC_CTYPE (or probably LANG or LC_ALL, but
>    I haven't checked those variables) must be set (probably to a UTF-8
>    locale, but I haven't checked any locales other than "C" (no bug)
>    and "en_US.UTF-8" (bug)).
> 2. The --no-window-system command-line argument must be used.
> 3. The variable utf-8-compose-scripts must be set.
>
> At this point, various things start failing strangely.  The script
> demonstrates one of the failures.
>
> I hope this helps.
>
> Joe
>
> ----------------------------------------------------------------------
> #!/bin/sh
> #
> export LC_CTYPE=en_US.UTF-8
> emacs --no-window-system --quick --eval '(setq utf-8-compose-scripts t)' 
> --load "lao-util"
> #
> # You will now see an error message like this one (replace XYZZY by
> # the appropriate path for your system):
> #
> # utf-8-post-read-conversion: Recursive load: 
> "XYZZY/share/emacs/22.1/lisp/language/lao-util.elc", 
> "XYZZY/share/emacs/22.1/lisp/emacs-lisp/regexp-opt.elc", 
> "XYZZY/share/emacs/22.1/lisp/language/lao-util.elc", 
> "XYZZY/share/emacs/22.1/lisp/language/lao-util.elc", 
> "/home/jbw/local2/share/emacs/22.1/lisp/emacs-lisp/regexp-opt.elc", 
> "XYZZY/share/emacs/22.1/lisp/language/lao-util.elc", 
> "XYZZY/share/emacs/22.1/lisp/language/lao-util.elc"
> #
> # In fact, lots of things will fail with this error message after this point.
> ----------------------------------------------------------------------
>
> In GNU Emacs 22.1.1 (i686-pc-linux-gnu, GTK+ Version 2.8.20)
>  of 2007-06-27 on artemis
> Windowing system distributor `The X.Org Foundation', version 11.0.70000000
> configured using `configure  '--prefix=/home/jbw/local2' '--enable-debug' 
> '--disable-nls' '--with-x-toolkit=gtk' 'CFLAGS=-O0 -g3 -ggdb''
>
> Important settings:
>   value of $LC_ALL: nil
>   value of $LC_COLLATE: nil
>   value of $LC_CTYPE: en_US.UTF-8
>   value of $LC_MESSAGES: nil
>   value of $LC_MONETARY: nil
>   value of $LC_NUMERIC: nil
>   value of $LC_TIME: jbw
>   value of $LANG: nil
>   locale-coding-system: utf-8
>   default-enable-multibyte-characters: t





<Prev in Thread] Current Thread [Next in Thread>