On Wed, 2005-08-10 at 16:27 -0700, Devang Patel wrote:
> On Aug 10, 2005, at 4:07 PM, Mark Mitchell wrote:
> > Paolo Bonzini wrote:
> >>> OK, Dan tells me that bringing up DECL_IGNORED_P was idiotic.
> >>> So, I'll retract that bit. I do still think that "artificial" is
> >>> a weird name for this attribute. It doesn't mean anything to
> >>> people who aren't GCC hackers.
> >> What about "intrinsic", if it is for intrinsics?
> > Great suggestion!
> > Though, I rather agree with Dan:
> >> Thus, i'm half of the mind that a better approach is simply a
> >> table of
> >> function names that should be marked with this new attribute,
> >> stored in
> >> the compiler, so that the attribute doesn't have to be visible to the
> >> user at all.
> It requires some scheme to keep this table synchronized with manually
> edited various intrinsics headers.
Which have changed once every couple years, max
> It may be a good idea to generate
> these headers from some table ? In any case, this can be a project
> item for 4.2. We can always improve things incrementally!
If you actually promise to do the work, i have no problem with the
current patch (in theory) as a starting point.
> So I am
> interested to know whether this patch is OK (with "intrinsic" as an
> attribute name, or any other that you think is suitable) or not ?