[Top] [All Lists]

Re: CVS: cvs.openbsd.org: src

Subject: Re: CVS: cvs.openbsd.org: src
From: Michael Knudsen
Date: Thu, 31 Jul 2008 16:04:56 UTC
Newsgroups: fa.openbsd.source-changes

Quoting Constantine A. Murenin ([email protected]):
> Shouldn't these functions be named timeout_add_{s,us,ns}? The SI unit
> for second is s, microsecond/nanosecond is us/ns, and these are widely
> used in other tools like traceroute and systat sensors display. Why
> deviate with non-standard half-abbreviations?

I would expect these functions to be called their current names --
especially because of the naming convention used in the timeval struct
as Chris pointed out.

As long as there is no real issue with their current names, I see no
point in changing them.

<soaplove> reverse: yah, totallu.
<soaplove> Looks like some of my y fell off in transit. TCP sucks.

<Prev in Thread] Current Thread [Next in Thread>