fa.netbsd.current-users
[Top] [All Lists]

Re: NetBSD on Lenovo ThinkPad T400 - Intel 82567LM ethernet adapter

Subject: Re: NetBSD on Lenovo ThinkPad T400 - Intel 82567LM ethernet adapter
From: Kouichirou Hiratsuka
Date: Mon, 26 Jan 2009 16:31:12 UTC
Newsgroups: fa.netbsd.current-users

Hello,

At Mon, 1 Dec 2008 22:15:28 +0100,
Manuel Bouyer wrote:
> 
> On Mon, Dec 01, 2008 at 11:49:15AM +1300, Mark Davies wrote:
> > On Mon, 01 Dec 2008, Jean-Yves Moulin wrote:
> > > this patch works for me but the mii layer is not configured:
> > >
> > > OUI 0x000000 model 0x0000 rev 0 at wm0 phy 1 not configured
> > >
> > > It seems that kernel can't read data from phy. (netbsd-5.99.3/i386
> > > with ich9 chipset: 82801I mobile (AMT) LAN Controller).
> > >
> > > Any ideas ?
> > 
> > Note, I'm seeing the same thing on a Dell Optiplex 760 (ich10, 
> > 82567LM-3 LAN Controller).
> > See 
> > http://mail-index.netbsd.org/current-users/2008/11/26/msg006291.html
> 
> Most probably the way to talk to PHYs is different for this chip.
> Some more code may be needed; usually the FreeBSD driver is a good source
> or information (unfortunably Intel doens't make public documentation for its
> network chips)

I have a same NIC.  I'm trying to import em(4) driver from OpenBSD.

# uname -sr
NetBSD 5.99.7
# lspci | grep Ethernet
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network 
Connection (rev 03)
# dmesg | grep ^em
em0 at pci0 dev 25 function 0: ioapic0 pin 20, address 00:1f:16:xx:xx:xx
# ifconfig em0 inet 192.168.0.3/24
# ifconfig em0
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        capabilities=1
        enabled=0
        address: 00:1f:16:xx:xx:xx
        media: Ethernet autoselect (1000baseT full-duplex)
        status: active
        inet 192.168.0.3 netmask 0xffffff00 broadcast 192.168.0.255
        inet6 fe80::21f:16ff:xxxx:xxxx%em0 prefixlen 64 scopeid 0x1
# exit
$ scp 
192.168.0.1:/usr/pkgsrc/distfiles/openoffice-3.0.0/OOo_3.0.0_src_core.tar.bz2 .
OOo_3.0.0_src_core.tar.bz2          100%  175MB  24.9MB/s  23.2MB/s   00:07  
$

It seems to work but I don't know much about kernel.  Please review
and correct the files in the follwoing URL (if 0 and XXX are exist).

  http://www6.nsk.ne.jp/~hira/NetBSD/em-NetBSD.tar.gz

Original files:
  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_em.c?rev=1.206
  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_em.h?rev=1.43
  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_em_hw.c?rev=1.31
  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_em_hw.h?rev=1.27
  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/dev/pci/if_em_osdep.h?rev=1.10

best regards.
--
 Kouichirou Hiratsuka
   hira@xxxxxxxxxxxxx

<Prev in Thread] Current Thread [Next in Thread>